Why Install and Configure HaProxy LBR Failed?

I have completed the task. Please see my screenshots attached. Even though the task failed.

because in app server, port doesn’t set according to task. You have to set the port of apache 5004 not 80.

thanks,

@player001 But they asked the Default port probably in the question

if you will do ssh into app server 1 or 2 or 3. Default port already set in their app server for apache.
You have to set default port of http in haproxy server not in app server. I hope you got it my point.

thanks,

in the task you haven’t to change the httpd port to 80 for the app servers, the question was only to use the 80 for the haproxy and not for app servers

1 Like

you have to perform below steps:

  1. Check the port on which httpd service running on app servers.

  2. Install and configure haproxy on LBR server.
    * Make sure, set the port for haproxy frontend to default http port (i.e. 80) or the port in question.
    * Add the backend servers along with port (the port on which httpd is running on app srever).

1 Like

Dear,

I have also completed the task but unfortunate it failed, i have not found the port mentioned anywhere for app server, as u mentioned i have try to login into app server but its showing deny.

You have to find what port is set as a default in app server. You can check by ps -aux | grep httpd or to go into the httpd.conf file Listen line.

1 Like

I got it, I have tried to ssh into app server for the same but it doesn’t allow me.

Hi Tej,

Apache is running on 8086 on app1,2 and 3 in my case.


these are the settings I have set up for : vim /etc/haproxy/haproxy.cfg

running curl from jump server. I am getting the welcome results on all three servers.

verifying this step - Select port to view on Host 1 and after adding port 80 click on Display Port .

it is stuck at this page. could you please check and advise.

Task Status - Failed

Could you please check and advise where I am wrong??
thank you

You have to try from LBR server to display webpage.

Make sure service up and enable in all app server.

failed :cry:

Task Status - Failed

haproxy service on LBR Server is down haproxy is not able to connect to App Server 1 on port 8086 haproxy is not able to connect to App Server 2 on port 8086
haproxy is not able to connect to App Server 3 on port 8086
HaProxy load balancer is not setup correctly as website is not running on LBR URL

service enabled in app server 1 and 2 ?

yes, all three of them, I did verify it myself :frowning:

Don’t worry may be technical glitch Report to KKE support team. Have you verified haproxy port should be 80?

@Inderpreet @vijin.palazhi
Could you please check and advise, where did I go wrong?
or is this a system glitch. thank you
Swaroop

@Inderpreet @vijin.palazhi
Please comment.

Seems like Haproxy service was down on your LBR host, did you verify if service was up and running after you made changes in Haproxy config ? Since service went down so website never came up for you on LBR link.

how was I supposed to verify Haproxy service? from LBR host, I did curl IP along with the httpd port.
I have enabled httpd to run the services post reboot on all three servers. can you check from your end and let me know if Haproxy service was running correctly. Is this possible?
Thanks
Swaroop