Webserver Labs - Apache Tomcat - 01

Trying to install tomcat in the /opt directory… I cd’d into the correct directory and used “sudo curl” with the correct url to download the appropriate tar.gz file but when using the following command I can’t seem to unzip the file… also tried gunzip but that didn’t work either… not sure what I’m doing wrong.

thor@host01 /opt$ sudo tar -xvf apache-tomcat-8.5.53.tar.gz
tar: This does not look like a tar archive

gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error is not recoverable: exiting now

Downloaded the official v8 Tomcat release from the official website which is slightly different from above. I’m able to unpack the tar file but still can’t get through the lab

Tried to install via yum but can’t find the package

Also tried installing wget via yum and then using the command:

wget https://downloads.apache.org/tomcat/tomcat-8/v8.5.53/bin/apache-tomcat-8.5.53.tar.gz

…but that didn’t work either

Same problem occured with me, researching now

So I found the problem:
image

Apache deleted 8.5.53 version from ftp. and there is no valid file when you trying to download. ( i do not know, emulator showing there is a file as downloading but it is damaged file or something else)

I checked ftp, there is 8.5.54 version, I downloaded it and renamed folder name from 8.5.53 to 8.5.54 and passed this step :slight_smile:
Mr Mumshad, please update the Lab for newer versions.

1 Like

Same issue and when we visit the website the page is not available on apache tomcat i guess they have removed the older version.

Hi Dears,

We are investigating on it and will keep you updated as soon as possible .

We are sorry for any inconvenience.

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)