Virtualbox does not support Apple M1

I am going through the K8s for Absolute beginners and I am trying to access the URL for the minikube
minikube service hello-minikube
My terminal output:
:running_man: Starting tunnel for service hello-minikube.
|-----------|----------------|-------------|------------------------|

NAMESPACE NAME TARGET PORT URL
default hello-minikube http://127.0.0.1:60547
----------- ---------------- ------------- ------------------------

http://127.0.0.1:60547
:exclamation: Because you are using a Docker driver on darwin, the terminal needs to be open to run it.

I am not able to access URL even after toggling with firewall enabled.
Please advise on how to access in current configuration not able to use Virtualbox integration or possibly how to enable virtualbox integration with M1? Thank you.

Hello @mambamentality
Can you please check the exposed service?
using
$ kubectl describe svc servicename

Error from server (NotFound): services “servicename” not found

kubectl run no longer creates a deployment, it creates a pod as the instructions are slightly different now so it seems that you have created a pod, not deployment , check the below example to know the updated instructions :

1.RUN kubectl create deployment hello-minikube --image=k8s.gcr.io/echoserver:1.10

2.RUN kubectl expose deployment hello-minikube --type=NodePort --port=8080

3.RUN minikube service hello-minikube --url