Unable to ssh thor@app01 in ssl question number 08

Hi All,

I am not able to ssh to thor@aapp01 for question number 08 in lab. Please find the below screen for future refence .

.

Anyone can you please help to establish the connection.

Thanks
Govardhan N

One point to update while creating ssh-keygen for 7th question.
before creating the ssh-keygen I tried check command for whether we have existing .pub

  • “ls -l ~/.ssh/id_*.pub”

when I tried to generate with out admin user it is generating below error

Thanks & Regards
Govardhan N

@Govardhan, I was able to ssh to thor@app01 without issue. Please check the screenshot.

@tgp,

on 7th question itself not able to generate for the following command ssh-keygen -t rsa but if I am doing with sudo I am able to generate & it is saving in root user folder. But how to generate with out sudo user.

with out sudo user


with sudo user

@Govardhan, Please provide the full path as provided in the screenshot. It is working.

@tgp,

For me, I am getting above error as mykey failed : Permission denied and if you have zoom I can show you details. and I m give the same command as per your request in the screen shot.

@Govardhan, send a loom recording so that we can analyze it.

@tgp,

I can not upload the zoom recorded file and please find the below screen shot what commands I gave as input

  1. ssh-keygen -t rsa
  2. in the name filed as mykey
  3. Enter passphrase as empty
  4. 2nd passphrase as empty
  5. finally I got as saving key “mykey” failed: Permission Denied

Thanks
Govardhan

Hello @Govardhan
Please try again the steps in question 7 but when you enter the file in which you have to save the key enter the full path “/home/thor/.ssh/mykey” not “mykey” then you will not get permission denied error and you could proceed successfully to question 8 as your steps in it are right.

Thank you it is working after placing in particular path

@tgp /@KodeKloud

I can not proceed for the question 8 and please find the following below screen.

  1. I entry the command the ssh-copy-id -i ~/.ssh/mykey.pub thor@app01
  2. and ssh thor@app01
  3. mkdir -p ~/.ssh && touch ~/.ssh/authorized_keys, I’m trying to create the ~/.ssh directory as well as the authorized_keys file (command executed but not able find file in App01 server).
  4. Use the chmod command to change the file permission:
    chmod 700 ~/.ssh && chmod 600 ~/.ssh/authorized_keys`

but it is not working . can any one please help

@tgp

can you please reply on the above issue. I apricate your help !

all you have to do is to only use this command ssh-copy-id -i ~/.ssh/mykey.pub thor@app01 to copy the content noting that this is the only requirement.
After executing this command you have to click on check and it will work fine then.

After entering the above command incase it asks for password please enter mjolnir123