Two Jenkins tasks with -validation issue

Hello @rahul456 @Inderpreet @kodekloud3 @kodekloud3

Task: Creating chained build in Jenkins
would you guys be able to check my tsk, I believe I have done it properly but it failed. its not just me that have this issue, there are few more guys having same issue. here is the captured screens for the outcome of the two jobs
1- first job git triggered by pushing to the master branch (capture screen shows the job started by change in SCM, at the end of the job also shows that it has triggered the other job as a down stream job):

2- second job is a downstream job triggered by the first job with its stable and went through with success:

The error complains about

seems like 'manage-services' is not a downstream project for 'nautilus-app-deployment'

can you please check this for me??

Thank you in advance.

@rahul456 @Inderpreet @kodekloud3 @KodeKloud @kodekloud-support3

Task: Deployment Using Jenkins

Here is another one I am pretty sure about the validation issue with this, the port the question was asking to have httpd running on port 8081
but the error is complaining about not configuring httpd on port 8086

here is the outcome of my jenkins job:

Note: I didnt want to sent to review since no one can see the Jenkins ui.

@nashwan, can you please put tasks under review ?

@rahul456
sure thing done! below are the links of the review of both tasks.


@nashwan, as per question you should have configured httpd port to 8086 instead of 8081.

@rahul456
Yes I just noticed that although I am sure I coppied the port number but yeah cant do anything since the question is now showing 8086, but yes I would give that task another go.

Would you be able to take a look at the other task please

Thank you very much for your support.

@rahul456 actually retried that task again with "correct port, its still complaining about port is not configured correctly. sent it again to review just in case:

this is the command I used to change the port by the way and the web was running on that port when doing curl to host:port

sudo yum -y install httpd
sudo sed -i "s/80/8083/g" /etc/httpd/conf/httpd.conf
sudo systemctl restart httpd

So I tried the third attempt with the same exact configuration, it passes through this time, not idea whatsoever what has gone wrong. lost half points and quite considerible time without know what is the issue.

@rahul456 would you be able to check out this task please.


its still under review, I have uploaded the evidence of my work at the very beginning of this page.

Thank you again.

Hi @nashwan

Please check this thread.

@Inderpreet okey so you feel this is not enough evidence I provided. not a problem, I wont waste time will either redo it or pass it on and move to the next task, since everyone is complaining there is a validation issue. thanks

@nashwan Sure, enjoy your upcoming tasks.

@Inderpreet what would you think about this error for this task?

1- first job got triggered on the scm push
2- second job triggered when when the first job build was stable and only suppose to start httpd service. this error got nothing to do with the task.

:- Seems like webpage is not loading properly on App Server 1

@rahul456
can you please at least fix this for me to be able to send it to review again?

Creating Chained Builds in Jenkins	Jan 15, 2021 11:07:28 PM	Jan 22, 2021 9:04:16 PM	
800
Failed
View Details 

Request review is disabled on this task.
thanks

Hi @nashwan
The above error can occur due to multiple reasons like Apache service was down or maybe incorrect content was published to the Apache document root etc.

Creating Chained Builds in Jenkins is marked pending for you to try again .

@Inderpreet thank you very much mate!

Just stumbled upon this recent thread and saw the issue with Httpd not listening with the correct port. I want to point out that the problem is with the sed entry:

sudo sed -i "s/80/8083/g" /etc/httpd/conf/httpd.conf

This will replace the port correctly when it runs the first time. However, the subsequent times, the port will be changed from 8083 to 808383 (80 in 8083 will get replaced). Hence, the Httpd wouldn’t even startup. The task would’ve failed.

I noticed for the last successful attempt, the question asked you to change to port 6000. Hence, the regexp worked without issues. :wink:

A better way is to get sed match the whole line as:
sudo sed -i 's/^Listen 80$/Listen 8083/g' /etc/httpd/conf/httpd.conf

1 Like