Tomcat installed correctly but it says failed

My task failed for installing tomcat. I tested it and I could see the web page in the browser.
Please can you check it for me.

I had the same experience. I was able to hit the web application using the root url and it said failed. Tomcat package was not found. The task was to ensure the ROOT.war web application was installed not to install tomcat package.

Wow mine was the same result
When it say tomcat packages which packages do they talk about
Is there something am I missing?
What are those packages. I thought is the website works that will means all the packages was installed

I converted the “tomcat.tar.gz” with alien to tomact.rpm and then installed it as required with “yum install tomcat.rpm” on app03, I put the ROOT.xml in "/apache-tomcat-8.5.55/conf/Catalina / localhost "and then I checked page 80 as requested, and everything worked fine, but when I finished the request failed.

BECAUSE ?

On which location you have put the ROOT.war file.?
Please share the steps which you have done to complete this task.?

vi /apache-tomcat-8.5.55/conf/Catalina/localhost/ROOT.xml

You need to put ROOT.war file /usr/share/tomcat/webapps directory.
You need to edit server.xml file located at /etc/tomcat/ and configure the port accordingly given in question.
These above steps you need to be done.
Might be this reason your task getting failed.