To create a linux user non-interactive

where are full details of the task like (on which app server user needs to be created and user name is already given or we can use some name - as the error says user ‘mark’ …but i haven’t used ‘mark’ and didn’t see in task details…

Server/User details in the below URL :—

Thanks Tej for your prompt response. I have server username/password details…my question is more specific to the detail of task. which user (name) i have create in non-interactive mode and on which server (as there are 3 apps servers)…

It’s described in task. You have image of task?

I can see only " Create a Linux User with non-interactive shell" from the task.

please find the screenshot…thank you…

Your task got failed. Details only available when you are performing this task.

But you can see the reason of task failure by clicking on failed checkbox.

the task failed because with comment " - user ‘mark’ does not exist on stapp03 "…but i tried using a different name to create a user like:
ssh banner@stapp03
then at the prompt (after prompt on stapp03) : adduser abcd -s /sbin/nologin

but task failed with “- user ‘mark’ does not exist on stapp03”. my question is, from where this “mark” is coming, which i didn’t see in the task details, even server name (i just tried on stapp03)…

Create a Linux User with non-interactive shell

1 Like

You would have had the user required given to you in the task details.

“my question is, from where this “mark” is coming, which i didn’t see in the task details,”

Next time try to get a screenshot of the task in case this happens again, usually the elements such as usernames are in yellow text.

also, why would you add a random user like abcd instead of the one they asked you to create?

I was trying to complete this task but I am not able to do ssh to server or run a command with sudo… what is the issue?

Hello, rsachi
which server to whom?