@Tej_Singh_Rana @Mohamed Ayman , Need help with Troubleshooting Networking Prac . . .

V S Charan kumar Reddy Bakka:
@Tej_Singh_Rana @Mohamed Ayman , Need help with Troubleshooting Networking Practic etest…Q2…AFter chagding the path and re-creating kube-proxy pods…i see below error:

controlplane kubectl logs -f -n kube-system kube-proxy-l67l7 F0501 14:53:29.463179 1 server.go:490] failed complete: failed to decode: no kind "Config" is registered for version "v1" in scheme "<http://k8s.io/kubernetes/pkg/proxy/apis/config/scheme/scheme.go:29|k8s.io/kubernetes/pkg/proxy/apis/config/scheme/scheme.go:29>" controlplane kubectl logs -f -n kube-system kube-proxy-j5ndb
F0501 14:54:44.949247 1 server.go:490] failed complete: failed to decode: no kind “Config” is registered for version “v1” in scheme “http://k8s.io/kubernetes/pkg/proxy/apis/config/scheme/scheme.go:29|k8s.io/kubernetes/pkg/proxy/apis/config/scheme/scheme.go:29

Can you help with this?

Mohamed Ayman:
Please try again using those steps,

  1. Check the logs of the kube-proxy pods
    kubectl -n kube-system logs <name_of_the_kube_proxy_pod>
  2. The configuration file /var/lib/kube-proxy/configuration.conf is not valid. The configuration path does not match the data in the ConfigMap.
    kubectl -n kube-system describe configmap kube-proxy shows that the file name used is config.conf which is mounted in the kube-proxy daemonset pods at the path /var/lib/kube-proxy/config.conf
  3. However in the DaemonSet for kube-proxy, the command used to start the kube-proxy pod makes use of the path /var/lib/kube-proxy/configuration.conf.
    Correct this path to /var/lib/kube-proxy/config.conf as per the ConfigMap and recreate the kube-proxy pods.
    This should get the kube-proxy pods back in a running state.

I still face the same error as well please advise

controlplane $ kubectl logs -n kube-system kube-proxy-g675h 
F0514 20:21:36.897793       1 server.go:490] failed complete: failed to decode: no kind "Config" is registered for version "v1" in scheme "k8s.io/kubernetes/pkg/proxy/apis/config/scheme/scheme.go:29"

please find below a similar issue where the supplied config file was not relevant to the kube-proxy

Hi all

I managed to pull it of
I repeated the exercise and checked the parameters and apparently the below parameter was configured in the daemon set which is mentioned in the answer guide

/var/answers/answer2.md 



  --config=/var/lib/kube-proxy/config.conf

so I assume that you did the same mistake I did and used the one mentioned in the configMap

/var/lib/kube-proxy/kubeconfig.conf