@Tej_Singh_Rana For multiple scheduler - the changed scheduler is up & runni . . .

Deepak Ladwa:
@Tej_Singh_Rana For multiple scheduler - the changed scheduler is up & running, but when I create the pod with the reference to changed scheduler name - I don’t see the changed scheduler name as part of the pod describe command o/p. Can you please help me to identify the root cause.

Tej_Singh_Rana:
Hello, @Deepak Ladwa
Did you assign a schedulerName field in the pod definition file?

Deepak Ladwa:
Yes

Tej_Singh_Rana:
custom scheduler is up & running?

Deepak Ladwa:
are the port changes correct which I had shared

Deepak Ladwa:
looks like some issue with port changes

Tej_Singh_Rana:
If you’re assigning --secure-port=0 that means you’re disabling https service. Assign it to HTTP.

Tej_Singh_Rana:
Did you check the logs?

Tej_Singh_Rana:

--secure-port int     Default: 10259
The port on which to serve HTTPS with authentication and authorization. If 0, don't serve HTTPS at all.

Deepak Ladwa:
Got it. Thanks.

Deepak Ladwa:
@Tej_Singh_Rana
Events:
Type Reason Age From Message


Normal Scheduled 3m59s Successfully assigned default/nginx to node01
Normal Pulling 3m59s kubelet, node01 Pulling image “nginx”
Normal Pulled 3m58s kubelet, node01 Successfully pulled image “nginx” in 477.280631ms
Normal Created 3m58s kubelet, node01 Created container nginx
Normal Started 3m58s kubelet, node01 Started container nginx
controlplane $ cat nginx-pod.yaml
apiVersion: v1
kind: Pod
metadata:
name: nginx
spec:
containers:

  • image: nginx
    name: nginx
    schedulerName: my-scheduler
    controlplane controlplane kubectl -n kube-system get pod my-scheduler-controlplane
    NAME READY STATUS RESTARTS AGE
    my-scheduler-controlplane 1/1 Running 4 6m10s
    controlplane $

Deepak Ladwa:
@Tej_Singh_Rana still no luck. Even though my-scheduler is up & running and proper reference is defined in pod definition file

Tej_Singh_Rana:
Can you please check?

$ kubectl describe po pod-name | grep -i scheduler

Tej_Singh_Rana:
You can see the same result:

$ kubectl get events -owide

Deepak Ladwa:
controlplane kubectl describe pod nginx | grep -i scheduler controlplane

Deepak Ladwa:
103s Normal Scheduled pod/nginx my-scheduler, my-scheduler-controlplane Successfully assigned default/nginx to node01 103s 1 nginx.165c7750aac40951

Deepak Ladwa:
under events section it is showing. But not on the describe option

Deepak Ladwa:
strange

Tej_Singh_Rana:
Maybe it’s a bug. Please ignore and go ahead.

Deepak Ladwa:
Thanks for the support.