Tasks marked as failed even though it is done correctly

Hello Admin,

Can you please review my tasks as I believe everything was done correctly and it still marked me as failed. It has been a while now and I want to start with other tasks. This is a blocker at the moment. I dont want to be paying £35 a month for not having tasks looked at!

https://kodekloud-engineer.com/#!/task_review?task_id=6028fd2849331edacfb6ce38

Seems like the only answers I am getting are from people who are cut and pasting someone elses answers which is not ideal and should be discouraged!

Hi @kevin.munue.fong

The -i i.e --include option of zip command is used to include the specific files or directories, I don’t think it supports the absolute path. In simple words if you were using -i option you should have run your zip command from /var/www/html directory more over a trailing / is mandatory I believe with directories in such case so it was supposed to be news/ rather than just news.

Now what happened here is you command worked without error but your zip archive was probably empty as it was not able to find any files/directories that need to be added to the archive, you should have tried to extract the archive after creating it to confirm you script is working as expected.