Task validation issue - Install and configure web application

Dear @Inderpreet @kodekloud-support3,

Why I am getting this error (on screenshot) while I have the index.html file under the ecommerce directory and opened TCP 8080 for web traffics as instructed? please check.

image

Cheers,
Salim

I am facing same issue. Please help!!!

Everything just works.

I even validated from Jump server using below commands:

curl http://172.16.238.10:8080/blog/

curl http://172.16.238.11:8080/blog/

curl http://172.16.238.12:8080/blog/

curl http://172.16.238.10:8080/games/

curl http://172.16.238.11:8080/games/

curl http://172.16.238.12:8080/games/

Everything worked. Even i tried using public IP URL. It just worked. Yet it says task failed.
Please note that I had already cleared this type of task in past and now it is saying task failed.

@Inderpreet @kodekloud-support3

Can someone respond please! @Inderpreet @kodekloud-support3 @KodeKloud @mmumshad

Thanks.

Dear support team,

Any update please?can someone please check this? it has been 3 days now, no response! @Inderpreet @KodeKloud @kodekloud-support3 @mmumshad.

I appreciate the hard work. Thanks

Cheers,
Salim

@Salim @salilpune1 this is marked Pending for you, please try again.

Thanks @Inderpreet and welcome back :grinning:.

1 Like

Thank you again.

Unfortunately task check is still having issue? I verified before commit but same issue.

Task Status - Failed

- ‘news’ webpage is not working on App Server 1

My verification step:

thor@jump_host /$ curl http://172.16.238.10:8080/news/

KodeKloud

This is a sample page for our news website

@Inderpreet. I am getting the same error as @salilpune1 though the news folder is placed under /var/www/html/news on stapp01.

Below are my configs and I verified it to be working fine.

Validation:

Thanks.

Cheers,
Salim

oops apologies for that, please try again.

1 Like

@Inderpreet, It worked. I was able to successfully complete the task. Thank you.

Thank you…!!

It worked.

Hi Salim, @salilpune1
I am assigned this task.
As per 3rd question.
c. There are two website’s backups /home/thor/news and /home/thor/games on jump_host . Set them up on Apache in a way that news should work on link http://<<lb-url>>/news/ and games should work on link http://<<lb-url>>/games . (do not worry about load balancer configuration, as its already configured).

These are the two files in the jump server. should I copy them under application servers individually? or should I copy them under the storage server data folder?


while I am trying to copy the files from the jump server to the storage server.
I am getting an error message as per below. Please check and advise.

in one of the threads, I saw a user pointing to this link for updating the settings.
https://httpd.apache.org/docs/2.4/vhosts/examples.html

When I verify httpd.conf file, the virtual host section itself is not present.

Awaiting your valuable inputs.
Thanks
Swaroop

@swaroopcs88 if these apps are using NFS share for /var/www/html then you can copy data to any server in this location and that should reflect for all.

2 Likes

Hi @Inderpreet
I have copied demo and ecommerce - index.html files to /data/demo/ and /data/ecommerce/ folder of storage server. when I am trying to verify them, it is not loading.




what else should I set up??

@salilpune1 @Inderpreet @Salim @player001 @mouador
Please check and advise.
Thanks
Swaroop

Hello, swaroopcs88
Actually you are directly accessing katacoda.com/ecommerce something. That’s not a correct way. You have to do ssh into the LB server and then do above things. I guess there is a pre-setup on port 80. Yeah i saw you used virtualhost that’s fine.

Hi Tej,
Sorry I am unable to follow you.
when you say accessing directly? can you please give an example of what it means?
I have done all the changes by SSH to application servers. I am unable to follow your inputs. Thanks for your time.
Swaroop

In the above image, you wrote directly
2886979532-80-kitek29x.environments.katacoda.com/demo/”. Which is not correct if you are in the any of the appserver. You have to do ssh into LB server and perform this steps in there or do with curl command in the app server with exact configured port. Like: –

curl http://172.16.238.10:8080/ecommerce

Hi All,
I was following the same steps with my initial attempts.
Not sure, why it did not work earlier. I was able to complete the task within the deadline.
Thanks for your valuable inputs @player001 Tej.
Thanks
Swaroop