Task Squid in kodecloud engineer

I had completed my task for kodecloud engineer and the task for installing squid is complete and the service status shows active as per output below, but task says failed.


hor@jump_host / thor@jump_host / ssh tony@172.16.238.10
tony@172.16.238.10’s password:
Last login: Tue Sep 22 04:58:14 2020 from jump_host.linuxenableserviceboot_app_net
[tony@stapp01 ~] [tony@stapp01 ~]
[tony@stapp01 ~]$ sudo systemctl status squid
[sudo] password for tony:
● squid.service - Squid caching proxy
Loaded: loaded (/usr/lib/systemd/system/squid.service; disabled; vendor preset: disabled)
Active: active (running) since Tue 2020-09-22 05:01:29 UTC; 8min ago
Process: 763 ExecStart=/usr/sbin/squid $SQUID_OPTS -f $SQUID_CONF (code=exited, status=0/SUCCESS)
Process: 758 ExecStartPre=/usr/libexec/squid/cache_swap.sh (code=exited, status=0/SUCCESS)
Main PID: 764 (squid)
CGroup: /docker/711aadf1e60d4cba6aa6f592bdacbb51ec72d4ec4ed8c34a32d78e97dc201997/system.slice/squid.service
├─764 /usr/sbin/squid -f /etc/squid/squid.conf
├─766 (squid-1) -f /etc/squid/squid.conf
└─767 (logfile-daemon) /var/log/squid/access.log

Sep 22 05:01:29 stapp01 systemd[1]: Starting Squid caching proxy…
Sep 22 05:01:29 stapp01 squid[764]: Squid Parent: will start 1 kids
Sep 22 05:01:29 stapp01 squid[764]: Squid Parent: (squid-1) process 766 started
Sep 22 05:01:29 stapp01 systemd[1]: Started Squid caching proxy.
[tony@stapp01 ~]$

@sandeepkallazhi, can you please share your KKE user name ?

my username is my email sandeepkallazhi@gmail.com

@sandeepkallazhi, as per question you should enable the service of ‘squid’ on all app servers.

@rahul456 I do understand that and I have done it. The video of the work clearly says its enabled on all app servers. But the task fails saying its failed on app1. Please look at the video and you can see its installed and running on all of it

@sandeepkallazhi, since usually validation start checking from app01 so it failed there and didn’t check for the rest of the apps, if you missed to enable it on any or on all apps, its going to fail.

@rahul456 I am iterating. The video of the task clearly says its enabled. See the screen shot for app01 which shows that the service is running. I don’t understand what is the issue. This is clear false positive. I am going to drop this and continue with new task when it appears.

@sandeepkallazhi, i think you are confused between running and enabled state. “enabled” means it will automatically start on boot. Please check this link for more details

I went back to the task and I see they only want it to enabled and not necessarily start it. I started it and not enable it. I rushed into the solution. My bad. Thanks for the review