Task: open a port on firewalld and make zone public on backup server

Below is the screenshot of my work. I opened the firewall on port 5002 and made zone public just as asked on the backup server. However, the task still failed.

Never mind. It’s so crazy, it failed because I had permanent flag in it which states that config survives reboots. Why did it have to fail, it wasn’t explicitly asked that it shouldn’t survive reboots. The task is still correct but failed all the same. What a shame