Task is marked fail even though the squid service was up and running

Screen shot attached.The task was marked fail because squid was not running on app server 1.But see attached screenshot.Squid was running

See below:


thor@jump_host / thor@jump_host / ssh tony@172.16.238.10
tony@172.16.238.10’s password:
Last login: Wed Sep 2 15:23:39 2020 from jump_host.linuxenableserviceboot_app_net
[tony@stapp01 ~]$ sudo service squid status
[sudo] password for tony:
Redirecting to /bin/systemctl status squid.service
● squid.service - Squid caching proxy
Loaded: loaded (/usr/lib/systemd/system/squid.service; disabled; vendor preset: disabled)
Active: active (running) since Wed 2020-09-02 15:24:37 UTC; 8min ago
Process: 217 ExecStart=/usr/sbin/squid $SQUID_OPTS -f $SQUID_CONF (code=exited, status=0/SUCCESS)
Process: 212 ExecStartPre=/usr/libexec/squid/cache_swap.sh (code=exited, status=0/SUCCESS)
Main PID: 218 (squid)
CGroup: /docker/7d09ff5fa932a7bac87add69dd322e42c515a748a8911664fde47246a893311e/system.slice/squid.service
├─218 /usr/sbin/squid -f /etc/squid/squid.conf
├─220 (squid-1) -f /etc/squid/squid.conf
└─221 (logfile-daemon) /var/log/squid/access.log

Sep 02 15:24:37 stapp01 systemd[217]: Executing: /usr/sbin/squid -f /etc/squid/squid.conf
Sep 02 15:24:37 stapp01 squid[218]: Squid Parent: will start 1 kids
Sep 02 15:24:37 stapp01 squid[218]: Squid Parent: (squid-1) process 220 started
Sep 02 15:24:37 stapp01 systemd[1]: Child 217 belongs to squid.service
Sep 02 15:24:37 stapp01 systemd[1]: squid.service: control process exited, code=exited status=0
Sep 02 15:24:37 stapp01 systemd[1]: squid.service got final SIGCHLD for state start
Sep 02 15:24:37 stapp01 systemd[1]: Main PID guessed: 218
Sep 02 15:24:37 stapp01 systemd[1]: squid.service changed start -> running
Sep 02 15:24:37 stapp01 systemd[1]: Job squid.service/start finished, result=done
Sep 02 15:24:37 stapp01 systemd[1]: Started Squid caching proxy.

Hi @srividc,

The task failed because squid service not enabled so you have to enable It through the following command:
sudo systemctl enable squid

1 Like