Task - Install and configure HaProxy LBR

Hi Indrapreet,
I have completed the task ’ Install and configure HaProxy LBR’ and tested it successfully.

Please find the attached screenshot here. Kindly review my task and advise. RegardsHaProxyLBR.pdf (1.2 MB)

@sairamakrishna did it fail for you despite performing all steps correctly ? or what issue you are facing ?

Hi Indrapreet, thanks for your response. Yes, I have performed all steps, installing haptic on ALB and configuring by adding app servers with port 8083(which all 3 app servers listen to) and keeping default port 80 etc, and even tested successfully for all app servers. Still the task completion status showed failed. Kindly look into it. Thanks for your time…Regards Sairam

Sorry I misspelled your name Inderpreet…also please read Installed ‘HAProxy’.,there is a typo there…Regards

@sairamakrishna instead of configuring backend static you should have configured backend app. Website was working on app URLs as it was already configured but you should have checked that it works on LBR link as well.

1 Like

Inderpreet, I didn’t get you. I have checked the webapp as well by clicking the + on the terminal and giving port 80, and also I have used curl from LBR server to all app servers and received response successfully. Not sure why the task result is showed failed though performing all required.
Please advise…

Hi Inderpreet, I hope you are buzy. Please review my previous task and advise ( this is for task: Install and Configure HAProxy LBR)

today, I just completed task: ‘IPtables installation and configuration’ , I have performed all required steps on all 3 servers, but still task completion status is failed.

steps performed on all 3 servers:
1.Install iptables-services using yum
2. started and enabled iptables/ip6tables services
3. executed below two commands:
iptables -A INPUT -p tcp --destination-port 5002 -s -j ACCEPT
iptables -A INPUT -p tcp --destination-port 5002 -j DROP
4. service iptables save

error says: “- Apache service on App Server 1 is not reachable from LB host”
but I did curl to all 3 servers (eg. curl stapp01:5002) from LBR server.

Please advise.