Task failed: kubernetes redis deployment

Hi @Inderpreet @mmumshad @kodekloud-support3
I have configured everything which was mention in task . But task got failed
Please verify that from screenshots

Hello, roopal.mishra
What is the error message?

label name redis not found but I mention that.

Thanks for reporting, They will look into it.

@Inderpreet
please look into issue.

@Inderpreet @KodeKloud
please provide update on this.

Hi @Inderpreet
do you got any chance to look into this issue it has been 5 days since I am following this. Please provide update .
Thanks

Hi @rahul456,
could you please check and provide update on this.
Thanks

@roopal.mishra How did you scheduled this to run on MASTER node?

As mentioned here: Kubernetes Redis Deployment-need help

Always mine is running on NODE01… Can you please tell me, how to rectify this?

Please use nodeName or Nodeselector options

@ASAAC As we can see in the below manifest, I mentioned that Selector role: master. But its NOT working. Can you pls check my manifest file… what could be the problem.

apiVersion: apps/v1
kind: Deployment
metadata:
  name: redis-deployment
spec:
  selector:
    matchLabels:
      app: redis
      role: master
  replicas: 1
  template:
    metadata:
      labels:
        app: redis
        role: master
    spec:
      containers:
      - name: redis-container   
        image: redis:alpine
        resources:
          requests:
            cpu: 1
        ports:
        - containerPort: 6379
        volumeMounts:
        - mountPath: /redis-master-data
          name: data
        - mountPath: /redis-master
          name: config
      volumes:
      - name: data
        emptyDir: {}
      - name: config
        configMap:
          name: redis-config
          items:
            - key: redis-config
              path: redis.conf

Please see below link as ref docs.

Hi,
include this in spec section so deployment will schedule on master only.
nodeName: master
tolerations:
- key: node-role.kubernetes.io/master
operator: “Exists”
effect: “NoSchedule”

1 Like