Task 17 - Linux Network Services

Hi Team,

I’ve fixed the apache issue on the server and started the services properly and i can see the service is listening to the mentioned port as well on all the servers. Not sure why the task is showing as failed.

Can someone check and let me know.

Attaching the output below:

root@stapp01 ~]# ps -ef | grep -i http
root 1954 1 0 13:07 ? 00:00:00 /usr/sbin/httpd -DFOREGROUND
apache 1955 1954 0 13:07 ? 00:00:00 /usr/sbin/httpd -DFOREGROUND
apache 1956 1954 0 13:07 ? 00:00:00 /usr/sbin/httpd -DFOREGROUND
apache 1957 1954 0 13:07 ? 00:00:00 /usr/sbin/httpd -DFOREGROUND
apache 1958 1954 0 13:07 ? 00:00:00 /usr/sbin/httpd -DFOREGROUND
apache 1959 1954 0 13:07 ? 00:00:00 /usr/sbin/httpd -DFOREGROUND
root 2293 2258 0 13:12 pts/0 00:00:00 grep --color=auto -i http
[root@stapp01 ~]# netstat -an | grep 3002
tcp 0 0 0.0.0.0:3002 0.0.0.0:* LISTEN[root@stapp01 ~]#

root@stapp02 ~]# ps -ef | grep -i http
root 219 1 0 12:19 ? 00:00:00 /usr/sbin/httpd -DFOREGROUND
apache 220 219 0 12:19 ? 00:00:00 /usr/sbin/httpd -DFOREGROUND
apache 221 219 0 12:19 ? 00:00:00 /usr/sbin/httpd -DFOREGROUND
apache 222 219 0 12:19 ? 00:00:00 /usr/sbin/httpd -DFOREGROUND
apache 223 219 0 12:19 ? 00:00:00 /usr/sbin/httpd -DFOREGROUND
apache 224 219 0 12:19 ? 00:00:00 /usr/sbin/httpd -DFOREGROUND
root 485 290 0 13:11 pts/0 00:00:00 grep --color=auto -i http
[root@stapp02 ~]# netstat -an | grep 3002
tcp 0 0 0.0.0.0:3002 0.0.0.0:* LISTEN
[root@stapp02 ~]#

root@stapp03 ~]# ps -ef | grep -i http
root 178 1 0 12:19 ? 00:00:00 /usr/sbin/httpd -DFOREGROUND
apache 179 178 0 12:19 ? 00:00:00 /usr/sbin/httpd -DFOREGROUND
apache 180 178 0 12:19 ? 00:00:00 /usr/sbin/httpd -DFOREGROUND
apache 181 178 0 12:19 ? 00:00:00 /usr/sbin/httpd -DFOREGROUND
apache 182 178 0 12:19 ? 00:00:00 /usr/sbin/httpd -DFOREGROUND
apache 183 178 0 12:19 ? 00:00:00 /usr/sbin/httpd -DFOREGROUND
root 612 413 0 13:10 pts/0 00:00:00 grep --color=auto -i http
[root@stapp03 ~]# netstat -an | grep 3002
tcp 0 0 0.0.0.0:3002 0.0.0.0:* LISTEN
[root@stapp03 ~]#

image

Hi @shakthiprakash28

Your answer seems correct but still there are some doubts if it was a system issue or a genuine error. I am marking again this task as Pending for you, can you please give it an another shot.

Thanks
Inderpreet

Hello Inderpreet,

I tried starting the apache services back up and i’m still still the task is marking as failed. Attaching the screenshot for reference.

Kindly check and let me know.

image

Hi,

After starting the service did you ensure that Apache is reachable on respective port? You could try to telnet or curl it from jump host or from another host to confirm.

Thanks
Inderpreet

Yes I checked on all the 3 app servers it was reachable on the mentioned port.

Kindly suggest what to be done next for this task? Answer request in the task I’ve completed it.

Hello everyone ,
Can anyone help me giving me some tips and tricks to solve this problem with apache test Connectivity ? I mean do you have some documentations or courses explaining how to solve this kind of problem ?
I Don’t need solution , but just some guide because I’m willing to learn in order to gain experience . I have seen Nothing intersting so far on internet .
Thanks in advance

try to learn from tutorials or follow documentations. If you feel bore then try it hand to hand on terminal.

Thanks , but do you have some tutorials or follow documentations ?

Hi,

Can you confirm on this task? I’ve completed the task successfully but it’s showing failed. Can you check and modify the result for the task according as ive completed the task correctly.

Thanks

Inderpreet ,
Can you give some tips to do the assessment on Linux Network services ? I 'm lost and I Don’t anything intersteting on internet to help me . Don’t you have some documentations or relevant tutorials that can help me understanding and fixing this problem ?

Hi @shakthiprakash28

Once you are able to start the Apache service it will be available on same host as its running locally, for example if you have started Apache service on App Server 1 and you try to access Apache from App Server 1 itself it will be available but you need to make sure its available from other hosts as well like jump host.

I hope it clarifies your doubt.

Thanks
Inderpreet

Hi @bagam_fleury

There is no such documentation from our end however you must be able to find relevant solutions on internet if you are clear with the requirements. As mentioned in the question you can use tools like telnet or netstat to identify service reachability and listening ports etc. Since you know well on which port Apache is running or supposed to be running so you can try to start its service and if you face any issues then try to figure out what is causing issues from logs or error messages you see.

Thanks
Inderpreet

just a clue: did you open the port in iptables on app server to telnet the service from jump box???

Hi ,

Yes i tried i tried the same as well. Can you give me access to the server again for that task, i can do that again and share the screenshots.

Thanks,

Hi Inderpreet,

Can you make Task 17 accessible again so that i can complete it again.

Hi @shakthiprakash28

Each failed task will be reassigned aromatically after some time, so please proceed with the next tasks and once you have this one reassigned you can give it an another try.

Thanks
Inderpreet

Hello Inderpreet ,
I have succeeded to solve the problem regarding apache as you can see on the screenshots , and I have Added some iptables rules on all the servers on the apache’s port .
However , I’m not arriving to access apache on server 1 from jump_host .


Can you help me ?

Hi,

Try to telnet Apache port on App Server 1 from jump host and see if you are able to connect.

Thanks
Inderpreet

Thanks for your fast reply ,
I have succeeded to ping app server1 from jum host and I don’t understand the reason why it doesn’t work for apache . I will telnet the port as you mentionned .