I’m contacting you because according to the solution, we have to delete the pod and create it again to solve the issue. I tried to used the command kubectl edit , and just edit the pod and it didn’t allow me to solve it.

Why the kubectl edit command didn’t work in this case?

Hello @Gabs ,

Have you tried submitting the task to review? No screenshot or any information is given here so it’s difficult to comment as a community user.
In general, not all properties of resources can be edited with the edit command. In many times you may have to export the resource definition to a file then delete the resource and crate it with the exported definition file (make sure you modify the exported definition file to recreation).


Hello, I was refering to step 7:

Update the pod red to use an initContainer that uses the busybox image and sleeps for 20 seconds

Delete and re-create the pod if necessary. But make sure no other configurations change.

I had to delete the pod red and create it again. I thought that I could modify it by just executing the kubectl edit pod command