Setup Puppet Certs Autosign

I have as well issue with this task
It failed wit message:

  • it seems like ‘autosign’ config file under ‘/etc/puppetlabs/puppet’ is not configured properly as per ‘dns_alt_name’ on puppet master i.e Jump Server
    Most likely there is a typo as it should be: dns_alt_names

Please have a look !

I also failed at this task with very same error, but not sure if I missed something or the marking system is bugged. I got all my client certificates autosigned OK but hitting FINISH I got this error. any hints as to what i may have missed?

Let see. I think that typo is an issue and validation script is looking for dns_alt_name and not for dns_alt_names. But let see what KKE team responds.

Did you configure the autosign.conf file? Which domain names did you put in there?

The same issue here

@andrzej, I think you have to add, “autosign = true” under [master] section of puppet.conf file.

The same result for me

i dont think so, u see in screenshots that autosign works fine.

1 Like

Thanks for reporting this guys, this question was having some missing information and we have modified it to add required details. This task has been marked as Pending for all who failed it so they can give it an another shot.

@Inderpreet

I kept getting
puppet-agent[494]: bad component(expected host component): jump_host.stratos.xfusioncorp.com
at the client restart puppet.

what did i do wrong?

Have you did entry alias name in your /etc/hosts?

Why does it says to use dns_alt_name instead of dns_alt_names.

Is this correct?

It is partially correct. The option is dns_alt_names and list all aliases for puppetserver. So to add one alias you can unofficially name it dns_alt_name.

Hi all! I got this message:

- Make sure puppet has signed certificates for ‘master’ node as well as for all ‘agent’ nodes

but testing puppet agents works…

I had the same problem with this task yesterday but mine is still marked as failed. Will mine be marked as pending so I can do it again?

- puppet 'autosign' config file is not found under '/etc/puppetlabs/puppet' on puppet master i.e Jump Server

My task is still marked as failed, will it be marked as pending like the other people?

@Inderpreet my initial attempt at this task is still marked as failed, I just redid that task with I believe the same steps and it worked this time and is marked as successful. According to this thread there was a bug in this task and people got another chance to re do it (marked as pending) or in another thread with a user named Jenna you marked it as complete (successful). Can you please either mark my first attempt as pending or sucessful?