Setup Puppet Certs Autosign : Make sure puppet has signed certificates for 'master' node as well as for all 'agent' nodes

Hi @Inderpreet ,

I was assigned a task to configure autosign cert for nodes. I did configure all the nodes and the jump host too, but the task failed with the below error:

Make sure puppet has signed certificates for 'master' node as well as for all 'agent' nodes



Regards,
Dipjyoty

I thought the prb is in dns_alt_name u have to add “s” dns_alt_names

But that’s not the error here, see the nodes are able to communicate with the master.

I tought that is a grep test with that value, I’m not sure
like grep dns_alt_names file.conf | wc -l

After doing all config settings you need to make sure all certificates have been signed before clicking on Finish (you can confirm which certificates have been signed by checking ls /etc/puppetlabs/puppet/ssl/ca/signed on master node) because sometimes it takes time to fetch/sign certificates, especially most of the students are missing cert for master node.

1 Like

Thanks, @Inderpreet, I will check this the next time I get the task.