Selinux Installation

yum install policycoreutils policycoreutils-python selinux-policy selinux-policy-targeted libselinux-utils setroubleshoot-server setools setools-console mcstrans

All these packages were installed.

I checked sestatus and it showed the below result on stapp02 server.

SELinux status:        disabled

Not sure, why task status shows failed?

required state of Selinux does not match on app03 server

1 Like

Hi Krishna,

Thanks for reporting this. You also need to make sure the change is persistent i.e the status must remain disabled even after system reboot. Also you mentioned about results on stapp02 host however in error message you shared its stapp03, is it a typo? You also need to make sure changes were done on correct server.

Thanks
Inderpreet

I installed SELinux and changed corresponding config to make the change permanent. After rebooting the app server, it never came up. And I failed the task.

Hi - I think the question mentions not to reboot the server? But thats OK. Please attempt the question again once its reassigned to you and let us know if you face issues.

@Krishna
after running installation script mentioned by you.
Below steps worked for me.
sudo vi /etc/selinux/config


In question it says rebooting is not required for now as there is a scheduled job to care of this. Also, question says ignore status of SElinux what it shows from the command line right now.

1 Like

Use this command to verify SELinux was configured correctly. One of my references: https://www.digitalocean.com/community/tutorials/an-introduction-to-selinux-on-centos-7-part-1-basic-concepts

cat /etc/selinux/config
SELINUX=disabled
1 Like

Hi,

i failed this question Selinux Installation , when it will be assigned to me again ?

Hi,

Don’t worry about the failed tasks, you might be reassigned that task in near future, please proceed with the other ones in your bucket.

Thanks
Inderpreet

Hello,
I completed the task and install all the packages of Selinux in App Server 1, the status was disabled and I did not restart the server as per requirements of the task, however, I still failed the task. I attached an image of this result.

Check it out my link above. :point_up_2:

Hello,

I have installed selinux packages and updated SELINUX=disabled in /etc/selinux/config.

But my task status is shown as failed.

What is the mistake here.

Hi Diego,

You were supposed to make changes in Selinux configuration as well to keep the required state persistent. This is something you missed hence the answer was marked as failed for you.

Thanks
Inderpreet

Hi Tenny,

Seems like you had a spelling mistake while making entry in Selinux config file. The state was supposed to be set to disabled but mistakenly you entered disbaled in the config so answer was marked as failed.

Thanks
Inderpreet

I’ve installed all the SElinux packages and updated /etc/selinux/config by settin SELINUX=disable in stapp02. But the task is mentioned failed. What’s wrong?

Hi,

We just reviewed your answer and found that you rebooted the stapp02 server after making changes however in question it is clearly mentioned not to reboot the server. Please note that in any of the questions you never need to reboot the servers.

I hope it clarifies why your task was marked as failed.

Thanks
Inderpreet

Thanks for the response.

Hello, what did I miss? Here’s what I did:

  1. connected to stapp02 as user steve
  2. installed SElinux
  3. disabled permanently
  4. checked sestatus for disable

Hi @samishken

As per error displayed w.r.t your task required packages are not installed on app server 1 seems like you were asked to make the required changes on App Server 1 instead of App Server 2. Hence task was marked as failed.

1 Like