Postgres - Install and Configure

Hi
I don’t understand how the postgres question (install and configure) is marked? I installed, the service, initialized the db, started and enabled the service.

I add my user/role, I add the DB, and I grant full permission to the newly created DB.
GRANT ALL PRIVILEGES ON DATABASE (db) TO (user);

Is this not the requirement? what am I missing?

Hi,

same with me but the task got failed with “PostgreSQL is not configured correctly, either user ‘kodekloud_rin’ and database ‘kodekloud_db5’ does not exist or user ‘kodekloud_rin’ does not has appropriate permissions on database ‘kodekloud_db5’ on DB Server” , everything was fine checked everything, what went wrong ?

Yip … I received the same error during my attempt

Hello everyone ,
I have faced the same issue too.

Even my task is failed. I am not sure what and where it went wrong.

Hello,

Sorry for this issue. We had some missing information in the question so we have updated it a little.

We have marked this task as Pending for all who failed it due to this issue. Please give it an another try.

Thanks! Working now! :muscle:

Hi @Inderpreet, I also had this problem. On the second time I had the same result.



@francilio marked Success for you. Some changes were in progress when you submitted it so it failed unnecessarily.

1 Like

Hello,

I have installed and configured postgres as required. but still, it shows the task as a failure. I have Rechecked from my end and it works properly.

what is the main issue in this scenario ? anyone can guide me what is the main issue with it? i haven’t work it on postgresql so facing issue.
psql -U kodekloud_rin -d kodekloud_db8 -h 127.0.0.1 -W

@francilio

@player001

You have to convert the given password to md5 and set it for user kodekloud_rin and then try to login with the plaintext given password.

done but still facing error
psql: FATAL: Ident authentication failed for user “kodekloud_rin”
@Preetesh

psql: FATAL: password authentication failed for user “kodekloud_rin”

hi KodeKloud Team,
Even i’ve made sure all the steps were configured properly . But still I get user or db not created properly . Can you please recheck or provide me any option to re-do the task ?

Hi @Preetesh

Seems like you missed this point

d. Make appropriate settings to allow local clients to connect to the <database> database through <databse_user> user using md5 encrypted password for authentication.

Please note that local clients might be running as different linux users but they should be able to connect to PostgreSQL using the credentials you created.

2 Likes

Hi @kaushik

You had a mistake here

pg

As per details given in the question you had to make sure to local clients are able to access the database using credentials you created.

1 Like

Why you are not changed database “kodekloud_db9” owner to kodekloud_top? is it not compulsory ?

hi Inderpreet,
Thanks for that . Please let me know what exactly had to be done here . It will help me correct my mistake . :slight_smile:

hi @Inderpreet Can you please let me know the correct way of achieving that requirement ? :slight_smile: