NFS Troubleshoot

Kindly solve this error and i have done as per the process. got the error as connection refused

Hello sudheer77,
Is it working fine in storage server? You can check by showmount -e ip-addr

@sudheer77

Hi! What changes have you done in the Storage server?

After configuring the vi /etc/exports
getting this error

“mount.nfs: access denied by server while mounting ststor01:/web”
Kindly resolve the issue

Can you provide the screenshot for /etc/exports?

Hello sudheer77,
remove the space from ip and (. Write /code 172.16.238.10(rw…

Getting the same error . I am not been able to find the mistake

“ mount.nfs: access denied by server while mounting ststor01:/code ”

@JDev
Kindly Help me in resolving the NFS Troubleshoot issue
I have done the following steps

@ Server
systemctl enable nfs
systemctl start nfs
vi /etc/exports
/code 172.16.238.10(rw,sync,no_subtree_check,no_root_squash,fsid=0)
/code 172.16.238.11(rw,sync,no_subtree_check,no_root_squash,fsid=0)
/code 172.16.238.12(rw,sync,no_subtree_check,no_root_squash,fsid=0)

@client
systemctl enable nfs
systemctl start nfs
mount | grep nfs
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw,relatime)
nfsd on /proc/fs/nfsd type nfsd (rw,relatime)
showmount -e 172.16.238.10
Export list for 172.16.238.10

[root@stapp01 ~]# showmount -e 172.16.238.15
Export list for 172.16.238.15:
/data 172.16.238.13

[root@stapp01 ~]# mount -t nfs 172.16.238.15:/code /var/www/html
mount.nfs: access denied by server while mounting 172.16.238.15:/code

after configuring /etc/exports
/data 172.16.238.13 is not getting update when i remove the /data line in /etc/exports

I second to the problem sudheer77 experiencing.

even after configuring share on storage server , its not reflecting /etc/exports entry.

can someone please help getting through this task.

let me know if iam missing something or there is some problem with storage server.

Hi krishna,

After configuring the /etc/exports . restart the server so that the changes made will be effected to the server.
and check the command showmount -e server ip.
it will show the export servers list

best of luck

1 Like

@Inderpreet
I again failed this task, could you please make it in pending status, so that I can give it another try. I thought the issue is with nfs server only, but it seems like I need to check all app servers too.

Hi yashpalsingh3737,

You just have to click on the answers provided in the review page in kodekloud engineering. Then you will get another attempt to perform the same task. Here is the more information : Updates coming! Review, Assist and Retry features

You need to verify the syntax in the /etc/exports file on server ststor01.

  1. Verify the name of the mountpoint that is being shared. And if required do the correction there.
  2. Kindly remove the space between the ip addresses, if any.
    Correct syntax will be -
    /mountpointname ip1,ip2,ip3(option1,option2,option3…)

save this file.
And then execute exportfs -r and exportfs -a and then check with command showmount -e. Verify that nfs service is running or not. If not, then start it.
Verify that nfs service is enable at boot or not.
And if required then only install the nfs server RPM packages if not installed.

Regards,
Prateek Gandhi