Nfs server broke

i have a problem when using
sudo mount -t nfs 172.16.238.15:/nfsdata /var/www/html
after waiting for some time i got error "mount.nfs: connection refused "
can anyone please tell what is the problem
the file /etc/fstab is also not present in servers kindly reply if anyone know the problem
how to do please give an idea

Hi,

Verify your work, you forget something.
and you don’t need the /etc/fstab because you only need to boot for this session

i am not know what i missed in this process i restart the server. doing mounting getting “connection refused”

Are you sure that the nfs server is started in the storage server and that everything is working fine ?
Also you need to verify : showmount -e [hostname or adresse IP]

yes nfs server is started in the storage server and that everything is working fine .i verified showmount -e 172.16.238.15


pls give an example for nfs troubleshooting
scenarios.

Hi,

As i see you didn’t put the good ip and the good folder in the nfs server, with the showmount you must see the ip of the app servers

Please show us the screenshot of /etc/exports file


it is not showing anything in /etc/exports.

I think you need to be on Storage Server. You’re showing App 1

I recommend reading this resource to help you complete the task.
This website has been a big help in completing most of the tasks.

https://www.tecmint.com/how-to-setup-nfs-server-in-linux/

1 Like

thankyou for your support

You’re welcome! :+1:


I am trying to verify below step for my requirement of the assignement.

I don’t see /nfsshare details in mycase.
also, running this command gives me an error.

nfsshare was only an example in the tutorial.
In your case it will be sudo mount -t nfs 172.16.238.15:/app /var/www/html
Please read the requirements carefully.
Another thing to note, make sure you are performing these commands on the client side (stapp01,02,03) not on the (server side ststor01).


access denied.

Make sure you have added the correct entries in /ect/exports file for each app server Client on the Server side (ststor01)

/ect/exports

 /code 172.16.238.10(<nfs options>)
 /code 172.16.238.11(<nfs options>)
 /code 172.16.238.12(<nfs options>)

@JDev
on storageserver, I have updated the file /etc/exports

I have updated options as below on /etc/exports file on storage server.

@JDev
@Inderpreet
@vijin.palazhi
@rahulsoni


why is it I am getting access denied? while running the above command as tony?

I think you should remove entries for /data and also make sure to run all required services and exportfs (look for exact syntx) command to reflect these changes.

suppose if I delete the /data line from /etc/exports on storage server and update.
as below.
/webapp 172.16.238.10(rw,sync)
/webapp 172.16.238.11(rw,sync)
/webapp 172.16.238.12(rw,sync)
on running showmount -e app1,2,3 IP Address.
I am seeing results as below.
image
Is this expected?