Minkube related question

Hi, I’d tried to download and install minikube in my office ubuntu server VM. But failed to download the related dependencies software when I entered the “minikube start” commands. None of the repositories my VM can reach to download. I guess it may related to firewall or proxy issue.
I’d searched Internet for setting the proxy in the VM. But still failed.
Can anyone help what and how to setup the proxy at ubuntu server so that “minikube start” can reach the Internet to download the requires software? Thank you.

Hi @arnold_lo

I suppose your want to install 'minkube'  from terminal.

If yes  , you can set proxy parameters from command line as follow:

(It's a  Temporary proxy setting)

export http_proxy=username:password@proxy_server_FQDN:port
export http_proxy=username:password@proxy_server_FQDN:port
export ftp_proxy=username:password@proxy_server_FQDN:port

A useful  link for other proxy setting depending on your specific needs:

https://www.serverlab.ca/tutorials/linux/administration-linux/how-to-configure-proxy-on-ubuntu-18-04/

If it’s a server at your office, do you also have a person/team that manages your IT Infrastructure? They might know better what’s going on

Samer,
Thanks. Yes. I am trying to install minikube from terminal in my office ubuntu server. I’d the same environment variables setup in my .bashrc file. When I ran the “minikube start” command, it came back with lots of error messages saying that “The image you are trying o add k8s.gcr.io/kube-proxy, etcd, kube-scheduler, coredns, kube-apiserver, kube-controller-manager, etc doesn’t exist!”
And it says “Existingdue to K8S_INSTALL_FAILED”!
I’d tested the Proxy I setup in the .bashrc file, it works! I had no problems to reach the Internet.
Do you have any other suggestions for me to trouble shoot the problems?
What about the off line installation?
BTW, I’d the minikube version v1.19.0 downloaded.
Thanks.

Even the install failed, when I checked “minikube status”, it shows the host is running, but the kubeconfig is “Misconfigured”, I need to run a “minikube update-context” to fix kubectl points to stale minikube-vm issue. Do you know what cause it? Is it because I could not download the above mentioned software? Or …? Thanks.

Please , follow  this links:

https://phoenixnap.com/kb/install-minikube-on-ubuntu