MariaDB task failed due to erroneous "mariadb server is not installed on DB Server" failure reason

Hi @peterwhite
Thanks for the detailed answers.
yeah i was trying to verify the way you did.
The answers certainly gave more clarity on the requirement.
Thanks
Swaroop

1 Like

@Inderpreet
I could able to open the wordpress from LBR link and i have performed all the steps .
Please check and update why the task has been marked failure for me ?

Hi, the same happened on my end just minutes ago.

@Inderpreet it’s still showing failed status for me .

@Darshan1893 FYI, your wordpress screenshot indicates that you completed the task incorrectly. If you had, you should have seen the blog posts like in my screenshots. Your screenshot only proves that wordpress is running, and you appear to have not restored the specified database dump since it looks like a fresh wordpress install…

@Darshan1893

Agree with @peterwhite this seems incorrect.

Hi @player001 @peterwhite I’m trying to do scp but I received following error:


I tried installing openssh and openssh-clients package for using scp but it says already installed.

Trying to install in jump_host or db server?

I want to send the file from jump to db host so installing it on jump host.

Hi @akshayyw,

It looks like you attempted to install those packages on jump_host instead of stdb01. This is based on you being prompted for peter@stdb01’s password before getting the scp: command not found error…

Peter

Try to install on db server.

2 Likes

Can you please provide me the command because I tried it from DB host still it is giving me error. I used the following command:
#scp thor@jump_host:/home/thor/db.sql /tmp/
It says: Connection refused error.
Also I gave the necessary permissions to /tmp in case required.

After installation of openssh-clients and openssh-server packages in db server.
It should be work fine. After this restart sshd service and then try your following command.

2 Likes

Sorry to bother you but I’m not able to do the scp thing. I did install the packages restarted the service. Not able to figure out what is wrong I tried on my host machine the same syntax for scp it worked.

P.S. Also tried doing scp with thor user

Have you checked port is active by netstat or ss command?

1 Like

In addition to @player001’s suggestions, try scp’ing from the jumphost. .e.g. scp /home/thor/db.sql peter@stdb01:/home/peter/db.sql. That should work if you’ve installed scp correctly on stdb01…

1 Like

I performed the same task.

I was able to see the databases from all the app servers.

I also configured my.cnf to skip-networking=0 and skip-bind-address.

I was still getting the Connection error issue.

Any thoughts on what might be wrong from my end?

@Inderpreet I have used wrong command while restoring the dump , is it possible to re-assign this task one more time ?

Thanks @player001 @peterwhite for helping me out , got my first 1000 points task sucessful!

1 Like