MariaDB task failed due to erroneous "mariadb server is not installed on DB Server" failure reason

Hi @kodekloud-support3, @Inderpreet,

I just failed this task with a “mariadb server is not installed on DB Server” error. As you’ll see from all of the screenshots below, wp-config was successfully configured and mounted on all app severs and I was able to remotely connect to the DB server and view the restored DB from ALL app servers…





I think you have to install and configure mariadb service in DB aka Database server but you configured in app server 1, 2 and 3. So that’s why error occured.

@player001 - thanks for the feedback, but your statement is only half-correct in my case. I installed MariaDB-server on stdb01 and granted remote access to the specified user on app servers 1, 2, and 3.

I only installed the MariaDB-client (the server was only installed on stdb01) on app server 1, 2, and 3 to verify that wordpress would be able to successfully connect from each of those hosts and to be able to obtain screenshot proof that the proper grants had been executed for remote access from each of those hosts.

Same case like me. The same output I had

@peterwhite Thanks for reporting this. This is marked as Success for you. Thanks for your patience.

Thanks @Inderpreet, much appreciated.

I was not able to copy the file over to DB server…tried local to remote and remote to local

scp db.sql root@ 172.16.239.10:/tmp/

scp -r thor@jump_host:/home/thor/db.sql /tmp

change the permission of folder that anonymous or other user can do perform that action.

if you the knew the password of target machine user of root.

scp db.sql root@172.16.239.10:/tmp/

  • if random user of db server like peter then before this, change the permission of that particular folder in db server. Because sometimes may not grant permission to perform action.
    scp db.sql peter@172.16.239.10:/tmp/
    and share screenshot of errors if this not works
    @labheshp
    thanks,

I ran this command as well…

scp db.sql peter@172.16.239.10:/tmp/

permmision denied error…not sure why it needs permision on /tmp

change the permission by chmod command .
$ chmod o+rwx /tmp/

For those having problems scp’ing files to remote hosts, here’s a couple thoughts and workarounds that I’ve successfully used…

  1. Verify whether scp exists on the remote host and install if missing
  2. scp as the user you use to ssh to the remote host, placing the files and that users’ home directory. You’ll have permission to do that - otherwise, you wouldn’t be able to ssh. Once there, you can move/rename the files as root using sudo…