Manual Scheduling Practice Test

While working on the Manual Scheduling Practice Test I am also faced the same problem as Santash. I do change the curl command as suggested by Vijin. But I am not able to schedule the pod using the command as per question number 3 where it says to schedule the pod to “node01”. Then I delete the pod and rec-create the same by manually entering the “nodeName” parameter. Then while trying to answer question number 4 to schedule the same pod to “master” node, I tried the curl command but receiving the failure message.

master $ curl --header “Content-Type:application/json” --request POST --data ‘{“apiVersion”: “v1”, “kind”: “Binding”, “metadata”: {“name”: “nginx”}, “target”: {“apiVersion”: “v1”, "kind: “Node”, “name”: “node01”}}’ -k https://172.17.0.61:6443/api/v1/namespaces/default/pods/nginx/binding/
{
“kind”: “Status”,
“apiVersion”: “v1”,
“metadata”: {

},
“status”: “Failure”,
“message”: “pods “nginx” is forbidden: User “system:anonymous” cannot create resource “pods/binding” in API group “” in the namespace “default””,
“reason”: “Forbidden”,
“details”: {
“name”: “nginx”,
“kind”: “pods”
},
“code”: 403

Please help.

Thanks,
Kunal

Hello Santash Jena,

As this worked for you. Could you please provide me the command that you had used in your case. Which succeeded.

Thanks,
Kunal