Linux User with non-interactive shell

@Inderpreet
I have an task of creating 「javed」user with non-interactive shell.
I created it but task status was Fail.
Please find the attached screenshots.


May I know where I am wrong?
Thank you.

Hi Hasmukhrathod,

I belive nologin shell will be in /sbin/

1 Like

I got the same assignment. Added the user and verified but the status failed.Screenshot attached.

Does the user need to be added with /sbin/? .What is the actual issue -why the error says no user has been added

/bin/false works not nologin

it’s simple… you are trying in jump host not in actual app server

1 Like

yes, it should be /sbin/nologin

/sbin/nologin also works

you are working on jump host… not on app servers :slight_smile:

Yep it works but he is using /bin so for /bin it should be /bin/false not /bin/nologin or he has change it to /sbin/nologin

tried with the same still


prompting the same failed

@ravirockyravindra You are doing on jump_host. Task is asking us to perform on a particular web server.

when i am trying to connect to stapp03 with password BigGr33n its not accepting.
Below command i m using to connect to stapp03
ssh banner@stapp03

you are not only on jump-server but you are using wrong command for no shell login. It supposed to be /sbin/nologin

Hi Riyaj,

Use the IP address instead.

Hi Team getting the same error here I created the Anita user as non-interactive user and associated to /sbin/nologin but I got failed.

Please can you tell me what I failed?

Thanks

Hi @eluctur

Can you please share your email ID.

Hi Inderpreet and Tech geeks, Please guide me how to access the “app03” box as required for this task. As i am totally new to Linux, your help would be much appreciated.Capture2

I am able to connect with this “ssh banner@stapp03” and password “BigGr33n”. My concern here is where do we get these details. username and password. Please suggest.,

Yes it happened.

But, please help me with my previous question.

Luca.turbesi@gmail.com @Inderpreet