Linux SSH Thor Passwordless Authentication

Hello Kode Kloud Support,

I thinks i solve the task as it was explained , But the result shows it’s a filed task.

So as i was searching through the community i think there is a misunderstanding of the task details for a lot of users .

So what i understand is that you have to make thor to ssh passwordless to every app server and what makes this trick got us is that there is already a thor user for each app server.

Hi @bader3000,

Welcome to the community!

In the future, it would help if you could also post a screenshot of the task description since, without that, those of us who don’t work for KodeKloud can only guess at why you got the task wrong…

That said, if I recall this task correctly, you were supposed to ssh as tony@stapp01, steve@stapp02, and banner@stapp03.


Thank you Mr @peterwhite for your support , And sure in the future i will consider screenshot every single information :slight_smile: .

1 Like

@peterwhite I ran to a similar issue, please advise once you get a moment
question: we need to make sure thor user on jump host has password
less SSH access to all app servers through their respective sudo users. So based on the requirements:

Setup a passwordless authentication for user thor on jump host to all app servers through
their respective sudo users.

received the following error below


Hi @Ali,

It would help to see a screenshot of the exact task description, but my understanding of that task, when I was last assigned it, was that user “thor” should be able to ssh, without password to tony@stapp01, steve@stapp02, and banner@stapp03.

Based on your terminal screenshot above, you ssh’d to each of those hosts using the ssh config for “root”, not “thor”. Each of those ssh commands should have worked without the “sudo” part in order to successfully complete the task. The “sudo” made ssh use the jumphost’s ssh configuration in ~root/.ssh instead of ~/.ssh.



thanks, I overlooked a simple task and without thinking further just pasted what was give in output. which had me confused, thinking I completed it correctly, but the fact i used sudo goes to show that it must have used root’s ssh config. You are absolutely correct. The ~/.ssh would be local to the user you are logged in and sharing the public key to User@IP. thanks point the silly mistake, Peter.

1 Like

Glad I could help, that happens to all of us! :slight_smile: