Linux Network Services

The HTTPDservice was running and the port was also connected

@kshanuanand while the screenshot does show the process as running and listening on port 5000, that in itself doesn’t guarantee it as being reachable. My first guess would be a firewall issue maybe ?

Hi anyone,

can you please explain why i was failed the task?
Apache is not reachable on port 3000 on App Server 1

Killed the process that was occupying the port for the httpd service.
Enabled & restarted the service
Got the same screenshots as above: service is up and running, and listening on the appropriate port.
Firewall wasn’t even installed; so even though I knew it wasn’t a firewall issue on the app server, I still went ahead and installed the firewalld package myself.
Added the port the apache server is listening on to the firewall, as well as the 8080/tcp.
Still says “Task Failed.”
Checked if it is the load balancer, but you can’t even ssh into the load balancer for this task.

Not sure what else should be done.

You need not install firewalld in this task. You need to check the iptables rules and allow it.