Labs are not loading in kodekloud and kodekloud-engineer since today morning

labs are not loading in kodekloud and kodekloud-engineer since today morning. Is anyone else facing similar issues ?

Hello, @prasannav387
Which labs?

Devops prerequisites labs and the kodekloud-engineer portal tasks are not opening. It says “Hang tight we are preparing the environment for you” for around 30 minutes…

Please logout, clear caches and login back. Let me know if it works.

Yes. Tried the following - cleared cache, cookies and logged out and logged in. Still its showing the same message and not connecting for a very long time…

Any specific lab you tried in DevOps prerequisites course? Please attach a screenshot.

This is one of the labs… However, issue is noticed with all the labs and kodekloud-engineer website tasks also…

Is there any kind of outage going on ?

I can access the labs.
Can you please try in incognito mode?

i am also not able to access labs since today morning.

Hi,

Tried accessing the site in incognito window through google chrome and tried opening the lab with internet explorer in Desktop computer.

Tried opening the lab with my android smartphone (google chrome browser), tried with mobile 4g internet and with wifi.

Tried all the above possibilities. Still facing the issue. Issue started happening only today. Till yesterday it was working fine…
Videos are loading fine. Issue is only with the lab. Internet speed is good - 150 Mbps jio fiber internet. Also, did speed test and confirmed speed is good. Facing no issues in streaming high quality videos. I am trying to access it from India for your reference.

Hi KodeKloud Team,

The issue seems to happen region specific. I tried connecting to Ultrasurf VPN which would connect to US/Europe VPN servers and I was able to connect to the labs. I think its not best practice to access training sites through VPN as it would show as multiple users logging in from same public ip address.

Without VPN, not able to access labs from India…
Is there any local cache from which each region accesses the Kodekloud labs. Since KodeKloud is powered by Kotacoda. Is it an issue from Kotacoda end ? Could you please check and rectify the issue at the earliest.

CKA practice test 2 ‘replica sets’ https://kodekloud.com/courses/675080/lectures/12038862

won’t load “hang tight”… I have already logged out, cleared cookies, logged in.

The problem is obvious in browser dev network tab, both websockets are pending, waiting for a response from the server.

wss://ws29.us.katacoda.com/socket.io/?dockerimage=kubernetes-cluster-running%3A1.19&course=mmumshad2&id=kubernetes-for-beginners-replicasets-new&embedded=true (snip’d url)

and

wss://environment-events.katacoda.com/?v=20201231&socketid=HAbxz3VeiXfMfLuvAAMB

0 bytes sent by the server after 10 minutes… every time I refresh it will likely spawn another set of pods on the backend, increasing the load and making the situation worse.

I am in New York, US

Same here since today morning. I’m from TX, US.

Connecting…

Hang tight! We’re preparing the environment for you.

But labs wont load. Tried incognito, cleared cache, but no luck.

Started this morning.

facing the same issue for last 2 days

Come on guys, 24 hours after my first report and it still won’t load “hang tight”

Super frustrated…

I switched from chrome to firefox and it works now

@player001
Thanks.!!
very strange that it works only via chrome incognito mode
going forward we need to access it like this?

anyone using chrome, try it via incognito mode

Some of the users in certain regions are experiencing a lab issue where the labs are stuck at the “loading page”. Our sincere apologies for the inconvenience caused. We are working with our lab hosting provider to get this issue resolved at the earliest. In the meanwhile, please try to clear cache and disable any Ad blocker if you have one enabled…