Kubernetes Redis Deployment - task failed

Hi all,

@Inderpreet

This task has failed with the below error, even if all seems ok :

image

Thanks in advance,

@b.kamal We can’t see your pod tolerations, can you provide the yaml manifest? Did you add the right toleration?

Hello,
@b.kamal Did you remove taints from master?

Hi,

Thank you for your replies.

I have used neither toleration nor removing the taint.

I have opted for the nodeName parameter, and the result as you can see the pod is
running in the master node :

@Inderpreet I think that the task must be updated if a specific solution is demanded.

What do you think?

Hi @Inderpreet,

I’ve also got this one failed as and validation is saying the label “name redis not found”. However the task asked to add a label “app=redis” I have done it as shown on the below screenshot. Please check

Validation

Cheers,
Salim

Hi @Inderpreet @KodeKloud @kodekloud-support3,
Can someone please update?.

Regards,
Salim

Hi ,
I am also trying to reach support team regarding the same task but didn’t get any response from them.

1 Like

I’m sorry to say that, but what I’m seeing is the fact that some people have the privilege to get support in just few hours but others are getting nothing

@b.kamal @roopal.mishra I think the load is high for @Inderpreet, there are so many posts and to respond to and the number increases each day as people keep joining the platform. I hope they respond to our queries soon.

1 Like

Even my task has failed. Can you look at it please @Inderpreet?

ya I can understand their situation but it has been 8 days since I am updating my post for support .

@kodekloud-support3 @rahul456 any update, please

Hi @Inderpreet,

Please check this one as well. The tag “app=redis” is there.

Thanks.

Hello, We have fixed some issues with this lab and it is marked Pending for whom it failed. Please give it an another try. Sorry for the inconvenience caused.

1 Like

Thanks @Inderpreet, I was supposed to get a new task today I hope it will come through as well.

Hi @Inderpreet ,

The task is not displaying the instructions. Please check.

Thanks for reporting, we are looking into it.

1 Like

Please try now, sorry for inconvenience caused.

Hi @Inderpreet,
Please see below. The same issue like previously attempted.
I tainted node01 like this kubectl taint nodes node01 gpu=true:NoSchedule, so that it does not get pods scheduled on it.
As per the screenshot below my toleration is exactly as was defined in master node, secondly the pod is running on the master node. Task failed does not even say what is wrong.

@ASAAC seems like all tests failed for you but this is strange. Could you please give it another try ?