Kubernetes plugin for PyCharm not working

Hi,
Trying to setup Kubernetes plugin for PyCharm following the instructions in “Kubernetes for Absolute Beginners”, I found several roadblocks not anticipated in the training:
1st You need to install dockers plugin dependency
2nd I got error “Plugin “Kubernetes” requires “com.intellij.modules.ultimate” plugin to be installed.” which seems to point that PyCharm community edition does not support this plugin.
Any hints? Am I pointing to the right Kubernetes plugin? Is the training outdated about the plugin installation?

thanks

1 Like

Hi,
This plugin https://plugins.jetbrains.com/plugin/9354-kubernetes-and-openshift-resource-support is the only one which supports the community edition.

Great!
that works now. Worth updating it in the training.

Plugin still not working. In your lecture, when selecting download, there is no option to pick ultimate or community edition. But now there is an option to select community edition by changing from ultimate. In spite of doing it, it gives you the same zip file. Downloaded multiple times but it gives same zip file and when tried to integrate with PyCharm it fails by asking for Docker plugin and then ultimate plugin.

Could you please provide the zip file as a download in your website? I feel like I am stuck with this. Was sailing through the course till now and yet to finish Developers and Admin courses. So, please help me get pass this hurdle asap. Thank you.

Found a solution. Uninstalled the latest pyCharm version (2020). Downloaded exactly the same version as it is refered in the course PyCharm Community Edition 2017.2.4 (https://www.jetbrains.com/pycharm/download/other.html)
The kubernetes plugin 2017 (09) worked with no issues. (https://plugins.jetbrains.com/plugin/9354-kubernetes-and-openshift-resource-support/versions) Thought other users might find it helpful if they also face hurdles with it. I have already started seeing the benefits of having a kubernetes supported IDE.