Kodekloud engineer task 5 disable ssh root login

Hi I just completed the task where I am asked to disable ssh root login for the app servers in the project but it failed me saying I didn’t do it for server 1. Please find attached a picture of the task after I completed it on the first server. you will see on the screenshot that the value is set to no. Thank you

Did you restart the sshd service afterwards?

no i didnt. Should i have done that for it to take effect?

Yes, most services don’t reload their configuration automatically. In general, you have to use something like systemctl to restart/reload the service.

So with the following commands, it should’ve worked:

  1. (optional) sudo sshd -t -> tests the configuration to see if there’s any errors. If there’s a mistake in the sshd config and you restart the server, you might not be able to get in anymore.
  2. sudo systemctl restart sshd -> restarts the sshd server and applies your updated configuration.

ok thank you. The funny thing is that i didnt restart it on the other 2 servers but the system only failed me saying that i didnt disable the ssh login on app1 only.

1 Like

Hello, @briscox1
Actually, it started to check from app01. After failing, it didn’t check for app02 and app03.

1 Like