Issue with MariaDB Troubleshooting task

After completing the lab once I click on Finish, it shows connection lost (Environment Expired).
I have successfully completed this lab below is proof.
Please mark this lab complete for me as I think there is some issue from the lab end.

Resolution - Please mark this task complete for me.

thor@jump_host / ssh peter@172.16.239.10 The authenticity of host '172.16.239.10 (172.16.239.10)' can't be established. ECDSA key fingerprint is SHA256:eZLwxWCJE+fJrh8AuHmDUZk00bHHtSzUZ8k8uxqQv5s.ECDSA key fingerprint is MD5:6e:fa:f6:16:f7:14:a5:38:92:74:c3:b6:df:e1:c9:c1. Are you sure you want to continue connecting (yes/no)? yes Warning: Permanently added '172.16.239.10' (ECDSA) to the list of known hosts. peter@172.16.239.10's password: [peter@stdb01 ~] sudo -u root -i

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

#1) Respect the privacy of others.
#2) Think before you type.    #3) With great power comes great responsibility.

[sudo] password for peter:
[root@stdb01 ~]# systemctl status mariadb
● mariadb.service - MariaDB database server
Loaded: loaded (/usr/lib/systemd/system/mariadb.service; disabled; vendor preset: disabled)
Active: inactive (dead)
[root@stdb01 ~]# cd /var/lib/
[root@stdb01 lib]# ls -l
total 48
drwxr-xr-x 2 root root 4096 Jan 27 11:05 alternatives
drwxr-xr-x 2 root root 4096 Mar 14 2019 dbus
drwxr-xr-x 2 root root 4096 Apr 11 2018 games
drwxr-xr-x 2 root root 4096 Nov 2 2018 initramfs
drwx------ 2 root root 4096 Aug 1 2019 machines
drwxr-xr-x 2 root root 4096 Apr 11 2018 misc
drwxr-xr-x 1 root mysql 4096 Aug 8 2019 mysql
drwxr-xr-x 1 root root 4096 Apr 4 01:23 rpm
drwxr-xr-x 2 root root 4096 Apr 11 2018 rpm-state
drwxr-xr-x 4 root root 4096 Oct 15 07:58 stateless
drwxr-xr-x 4 root root 4096 Aug 1 2019 systemd
drwxr-xr-x 6 root root 4096 Jan 27 11:05 yum
[root@stdb01 lib]# chown mysql:mysql mysql
[root@stdb01 lib]# ls -l
total 48
drwxr-xr-x 2 root root 4096 Jan 27 11:05 alternatives
drwxr-xr-x 2 root root 4096 Mar 14 2019 dbus
drwxr-xr-x 2 root root 4096 Apr 11 2018 games
drwxr-xr-x 2 root root 4096 Nov 2 2018 initramfs
drwx------ 2 root root 4096 Aug 1 2019 machines
drwxr-xr-x 2 root root 4096 Apr 11 2018 misc
drwxr-xr-x 1 mysql mysql 4096 Aug 8 2019 mysql
drwxr-xr-x 1 root root 4096 Apr 4 01:23 rpm
drwxr-xr-x 2 root root 4096 Apr 11 2018 rpm-state
drwxr-xr-x 4 root root 4096 Oct 15 07:58 stateless
drwxr-xr-x 4 root root 4096 Aug 1 2019 systemd
drwxr-xr-x 6 root root 4096 Jan 27 11:05 yum
[root@stdb01 lib]# cd /avr/run
-bash: cd: /avr/run: No such file or directory
[root@stdb01 lib]# cd /avr/run
-bash: cd: /avr/run: No such file or directory
[root@stdb01 lib]# cd /var/run
[root@stdb01 run]# ls
console dbus lock mariadb netreport sepermit sshd.pid systemd utmp
cryptsetup faillock log mount nologin setrans sudo user
[root@stdb01 run]# ls -l
total 12
drwxr-xr-x 2 root root 40 Apr 4 01:23 console
drwx------ 2 root root 40 Apr 4 01:23 cryptsetup
drwxr-xr-x 2 root root 60 Apr 4 01:23 dbus
drwxr-xr-x 2 root root 40 Apr 4 01:23 faillock
drwxr-xr-x 4 root root 80 Apr 4 01:23 lock
drwxr-xr-x 3 root root 60 Apr 4 01:23 log
drwxr-xr-x 2 mysql mysql 40 Apr 4 01:23 mariadb
drwxr-xr-x 2 root root 40 Apr 4 01:23 mount
drwxrwxr-x 2 root root 40 Apr 4 01:23 netreport
-rw-r–r-- 1 root root 40 Apr 4 01:23 nologin
drwxr-xr-x 2 root root 40 Apr 4 01:23 sepermit
drwxr-xr-x 2 root root 40 Apr 4 01:23 setrans
-rw-r–r-- 1 root root 3 Apr 4 01:23 sshd.pid
drwx–x--x 3 root root 60 Apr 4 01:23 sudo
drwxr-xr-x 14 root root 400 Apr 4 01:23 systemd
drwxr-xr-x 3 root root 60 Apr 4 01:24 user
-rw-rw-r-- 1 root utmp 384 Apr 4 01:24 utmp
[root@stdb01 run]# systemctl start mariadb
[root@stdb01 run]# systemctl enable mariadb
Created symlink from /etc/systemd/system/multi-user.target.wants/mariadb.service to /usr/lib/systemd/system/mariadb.service.
[root@stdb01 run]# systemctl status mariadb
● mariadb.service - MariaDB database server
Loaded: loaded (/usr/lib/systemd/system/mariadb.service; enabled; vendor preset: disabled)
Active: active (running) since Sat 2020-04-04 01:26:10 UTC; 14s ago
Main PID: 221 (mysqld_safe)
CGroup: /docker/99bb9b36defff9657caee14f9861825c4e993c5011da22a96b8c7c201d7c67bc/system.slice/mariadb.service
├─221 /bin/sh /usr/bin/mysqld_safe --basedir=/usr
└─382 /usr/libexec/mysqld --basedir=/usr --datadir=/var/lib/mysql --plugin-…

Apr 04 01:26:08 stdb01 systemd[221]: Executing: /usr/bin/mysqld_safe --basedir=/usr
Apr 04 01:26:08 stdb01 systemd[222]: Executing: /usr/libexec/mariadb-wait-ready 221
Apr 04 01:26:08 stdb01 mysqld_safe[221]: 200404 01:26:08 mysqld_safe Logging to ‘/va…’.
Apr 04 01:26:08 stdb01 mysqld_safe[221]: 200404 01:26:08 mysqld_safe Starting mysqld…ql
Apr 04 01:26:10 stdb01 systemd[1]: Child 222 belongs to mariadb.service
Apr 04 01:26:10 stdb01 systemd[1]: mariadb.service: control process exited, code=ex…s=0
Apr 04 01:26:10 stdb01 systemd[1]: mariadb.service got final SIGCHLD for state start-post
Apr 04 01:26:10 stdb01 systemd[1]: mariadb.service changed start-post -> running
Apr 04 01:26:10 stdb01 systemd[1]: Job mariadb.service/start finished, result=done
Apr 04 01:26:10 stdb01 systemd[1]: Started MariaDB database server.
Hint: Some lines were ellipsized, use -l to show in full.
[root@stdb01 run]# Connection to docker closed by remote host.
Connection to docker closed.

I’m also getting the connectivity issue with “DNS troubleshooting task”. There may be some issue with Lab end.

Hello Team / @Inderpreet

I too am facing the same issue after completing the task lost the connectivity.

Please check and update.

Thanks,
Mohamed

We are already looking into this issue from our end. We will update shortly once its fixed.

1 Like

I am facing similar issue. Even after starting mariadb service in DB server, my task shows failed.

@NarmathaSubramaniam sorry for this trouble, task is marked Success for you.

1 Like

Solution for the beginners: MariaDB Troubleshooting KodeKloud

1 Like

Thanks for sharing shawon10!

Not sure if it is ok to re-install, as it may wipe out all the data…

I just simply “yum update” it and it works fine to me…