Install Packages Using a Jenkins Job Still Stuck

Hi @KodeKloud and everyone,

I tried to reach out for some help with regards to this issue a few days ago, but my post seems to have disappeared in the feed, so I am posting the link here in the hope that someone from KodeKloud will respond:

I can’t move on to other tasks as a result of being stuck on this one.

Any help/suggestions &/or advice would be greatly appreciated.

Thanks in advance to anyone who can help :slight_smile:

sudo sed -i "s/80/8086/g" /etc/httpd/conf/httpd.conf

Try not to replace all the findings . just replace it in first entry for the port .

1 Like

Thank you @sadiq1425. I will try that via sudo sed '0,/80/s//3004/' /etc/httpd/conf/httpd.conf.

…I am still unable to get my job to run to completion, however. I’m facing a timeout issue/error related to Java (which I tried to install @ the beginning of my job just now…to no avail).

Did you install Java via the job httpd-php or manually via each app server?

Thanks again:-)

Hi @juliettet

You will find some help to complete this task on this link:

Good Luck

1 Like

Hi @samer,

Thank you for responding!

ssh -l jenkins  jenkins

cat << EOT > jenkins_job.sh

echo "creating main script on Jenkins server in /var/jenkins_home/ ..."
cat << EOF > jenkins.sh    
#!/bin/bash
sshpass -p "Ir0nM@n"  ssh -tt -o StrictHostKeyChecking=no  tony@stapp01  /home/tony/stapp01.sh
sshpass -p "Am3ric@"  ssh -tt -o StrictHostKeyChecking=no  steve@stapp02 /home/steve/stapp02.sh
sshpass -p "BigGr33n" ssh -tt -o StrictHostKeyChecking=no  banner@stapp03 /home/banner/stapp03.sh
EOF

If I try to ssh into the Jenkins server via the cli with password S3curePass, I am unable to do so:

Is there another CLI that is accessible from the Jenkins interface somewhere?

Thanks:-)

Try this to login to Jenkins

sshpass -p ‘j@rv!s’ ssh -q -o “StrictHostKeyChecking no” jenkins@jenkins

1 Like
ssh -l jenkins    jenkins      

Ssh password of jenkins's user is : always the same :  j@rv!s 

Hostname:jenkins	   
IP address:172.16.238.19	
Fqdn:jenkins.stratos.xfusioncorp.com	
Login:   jenkins	
Password: j@rv!s	    
Comment:Jenkins Server for CI/CD

Good luck! 


Do not forget to set :
- "apache' s port" as described in the current task
- the php version
In the gitHub link (it was 3000 and php71) 

You only have these 2 lines for each app server to modify:

sudo yum-config-manager --enable remi-php71  

sudo sed -i "s/80/3000/g" /etc/httpd/conf/httpd.conf



1 Like

Thank you @sadiq1425. I will try that:-)

Thank you @samer. I will keep your tips in mind. BTW, the link above returns a 404 now.

Cheers:-)

You're welcome,  in fact i found this task  difficult  for me , I took a long time to realize
that by writing script in bash, the solution would be easier

I decided to  think out of the GUI,  you 'll notice that i's 95 % command line and 5% graphical ,
 i prefer working with CLI than with GUI.

The link  is back again , sorry i disabled it ,  the KodeKloud admin does not like sharing task 
response.
Please  copy/paste  its content , it's a temporary link.

Good Luck 
Regards

1 Like

Hi @samer,

I feel the same. I find that the use of a GUI can often (though not always) make the task at hand a bit more confusing than necessary.

i found this task difficult for me

I’m glad I’m not the only one…

Thanks for your help :grinning:

…Update:

…still haven’ t resolved this issue:

@KodeKloud @rahul456,

Please see here (feed is not coming up in recent posts, so no one can see my most recent post…scroll down to end to see):

I couldnt see what you are doing as the initial command is truncated . From the error it looks like ssh passswordless authentication is not working for remote machine .

There shoudl be a course on Jenkins for us to learn on it

1 Like