Install and configure DB Server

Hello @Inderpreet, @admins

I have done the task and it failed as “website is not setup correctly as its not working on LBR URL”. i checked it and everything was fine but it failed. Could you please check and let me know what went wrong.

Hello @Inderpreet,

May i know the reason for this task failure if possible.

@sreenivas Sorry for delayed response. I don’t think you tested website finally with LBR URL ? Also the DB password seems incorrect:

dbp

Hi @Inderpreet,

I have set the DB password as “root” itself but still it got failed.

@sreenivas I don’t think you tested the website finally on LBR link. Please note that this was a remote DB server and the user you created is for localhost which was not going to work for the application on app servers. See this screenshot from your work.
db

1 Like

Hello @Inderpreet,

I have performed below steps for this task.
a. Install/Configure MariaDB server – done
b. Create a database – done
c. There is a DB dump restore done . - done
d. Create a user kodekloud_tim and set any password you like. - done – this done for localhost and for all app servers.
e. Grant full permissions to user on database for localhost and for all app servers .
f. Update database related details in /data/wp-config.php file on storage server – done

Note : I have tried to grant access to db user with 172.16.238.* ipaddress … I am getting the error connecting database via LBR link.
for troubleshooting purpose I have installed the mariadb client on one of the app server and tried to login to my DB . but it was throwing error to login to my DB I for got ot capture error message… ( from app server I was not able to connect DB even my remote config was right) .

So I closed that session for a second chance. this time II used the 172.16.239.3 ip address for granting the user access to DB. this time i was able to get the attached web page from LBR but task was failed.
and I was able to login to my DB from app01 server. attached config snaps here

Please let me know anyone succeeded to complete this task . if yes let me know what am missing here .
I have done this configuration in test set with two machine. LEMP with remote mariadb access. and it was working for me.

/thor/db.sql. Restore this database in newly create