Incorrect feedback on the Banner question

I feel, on the Banner question, I have setup the banners correctly on all app servers & db servers. Checked also the same before final submission.
But after submission, the result came as
Banner has not been set up on app server 1

I somehow feel, this is wrong. Can their is a way to verify it

Thanks,
Suman

Hi Suman,

Make sure you have copied the banner template to the right file on the servers mentioned?

Hi,

Yes, I did and also verified after starting sshd service.
This seemed ok as per checking. Intact I verified twice before final confirmation.

Can we recheck again or enable the question for me to answer again. It deducted marks uncessarily, I think

Hello everyone ,
I have succeeded to set up banner on app servers and db servers from Nautilus applications , but despite that the kodekould application has putted failed which I don’t agree . Because according to the architecture , the Nautilius application has on database server stldb01 and three web servers stapp01 stapp02 and stapp03.

1 Like

Yes, similar kind I have faced.
Not sure, why the answer was marked wrong.

Hello,
Had today the same issue. Could not find banner on any app and db servers. I read some threads here and it looks like template was available on jump host. I can not recall the question exactly but I do not think it was mentioned that template is on jump host. I just entered sample text for motd. Is it a way to repeat this question or at least remove failed result ?

Hello andrzej ,
The banner file is in jump_server . Therefore, you need to ssh to app servers and db servers in order set up banners on them . The hint is to use scp command and then restart ssh command .
I hope it 's gonna help you!!

This is clear, the issue is that they as far as I know did not mention that template is on jump server. I went to all servers checked /tmp than used find still nothing. SO I just used samle test and faile task grrrrrr…

Hi @begam_fleury/kodekloud-support3 team,
Just to ask on my issue. Can any solution be reached for this problem.

Thanks,
Suman

Hello,

Thank you for reporting this issue. We have modified the question a little to make it more clear on which server exactly the banner is saved.

About the validation we expect if mentioned banner is setup correctly on all required server as per question then task should pass, if it failed for anyone most probably task was performed on wrong server, or some of the servers were missed and possibly wrong banner was applied.

Further don’t worry about the failed tasks you will most probably be assigned these tasks again in future :slight_smile:

Thanks
Inderpreet

I failed the same task. Even though I verified the all the banners were present upon logging into stapp01, stapp02, stapp03, and stdb01.

I too face the same issue.I/m also failed in this task

Hello,

As per screen shot you shared, seems like some content of banner is missing. There should be a warning at the bottom something like in the screenshot

Please make sure you copy the exact banner which is given on the jump host.

Thanks
Inderpreet

1 Like

Yes, same problem noticed. screenshot attached.

Thank you for the clarification. I was able to complete the task successfully.

Hi laxminarayanp,

Thanks for reporting this. Seems like some maintenance was going on once you performed this task that’s why there is some expected error you are seeing. I have marked your task as pending manually so you can perform it again.

Sorry for this inconvenience.

Thanks
Inderpreet

Hello All,
I also think the same , I had copied on all the servers in /etc/motd but on one of the servers it is showing as not copied , please check if any change at the backend which could have caused issue

Hi spratap,

In your case the error seems valid i.e Banner has not been set up on app server 1. Don’t worry about the failed task you might be assigned the same in near future. Please proceed with the next tasks :slight_smile:

Thanks
Inderpreet

1 Like

Hey man ,
I’m not arriving to copy file on db server . can you help me out ? the scp command does’nt work for db server , but works for all applications servers .