Hi on the 'Troubleshooting section' the test 'Practice Test -Troubleshoot Networ . . .

Sandy Mauriz:
Hi on the ‘Troubleshooting section’ the test ‘Practice Test -Troubleshoot Network’ got some issues on question 2:
After changing the kube-proxy daemonset from: /var/lib/kube-proxy/config to /var/lib/kube-proxy/kubeconfig.conf
I get a different error from the logs:

1 server.go:490] failed complete: failed to decode: no kind “Config” is registered for version “v1” in scheme “http://k8s.io/kubernetes/pkg/proxy/apis/config/scheme/scheme.go:29|k8s.io/kubernetes/pkg/proxy/apis/config/scheme/scheme.go:29

And when going to question 3 the issue still doesn’t get resolved so I cannot do it either.

Could you please help, thanks

Tej_Singh_Rana:
Hello, @Sandy Mauriz @Vic
Please check again kube-proxy configMap. Correct file name is config.conf instead of kubeconfig.conf .

Mohamed Ayman:
Check this solution:
NetworkTroubleshooting-Q2.gif

Sandy Mauriz:
Hi @Mohamed Ayman @Tej_Singh_Rana thanks for that, but still after modifying the ds the kube-proxy is still on error but a different one. The new error it says ‘no kind Config’

I still face the same error as well

please advise

controlplane $ kubectl logs -n kube-system kube-proxy-g675h 
F0514 20:21:36.897793       1 server.go:490] failed complete: failed to decode: no kind "Config" is registered for version "v1" in scheme "k8s.io/kubernetes/pkg/proxy/apis/config/scheme/scheme.go:29"

please find below a similar issue where the supplied config file was not relevant to the kube-proxy

Hi all

I repeated the exercise and checked the parameters and apparently the below parameter was configured in the daemon set which is mentioned in the answer guide

/var/answers/answer2.md 



  --config=/var/lib/kube-proxy/config.conf

so I assume that you did the same mistake I did and used the one mentioned in the configMap.

/var/lib/kube-proxy/kubeconfig.conf