Hi, I have `Failed to pull image "busybox": rpc error: code = Unknown desc = Err . . .

Frantisek Ferencik:
Hi, I have Failed to pull image "busybox": rpc error: code = Unknown desc = Error response from daemon: toomanyrequests: You have reached your pull rate limit. You may increase the limit by authenticating and upgrading: <https://www.docker.com/increase-rate-limit|https://www.docker.com/increase-rate-limit> in Mock Exam 2. Should be fixed. Is this fixed in real CKA exam environment? Im going for exam tomorrow :face_with_monocle:

Tej_Singh_Rana:
Hello, @Frantisek Ferencik
Thanks for reporting, We are investigating…

Frantisek Ferencik:
Is this fixed in real CKA exam environment? Im going for exam tomorrow :face_with_monocle:

Tej_Singh_Rana:
If you see this kind of issue in the exam, you can complain to the exam organizer (Linux Foundation).

Frantisek Ferencik:
Is it allowed to run https://k8s.io/examples/admin/dns/dnsutils.yaml|https://k8s.io/examples/admin/dns/dnsutils.yaml in real CKA exam environment? Are there any restrictions regarding usage of images from public image libraries in real CKA exam environment?

Tej_Singh_Rana:
Where did you get this link from?

Frantisek Ferencik:
https://kubernetes.io/docs/tasks/administer-cluster/dns-debugging-resolution/|https://kubernetes.io/docs/tasks/administer-cluster/dns-debugging-resolution/

Tej_Singh_Rana:
Yeah, you can use.

Frantisek Ferencik:
Tej thanks

Vijin Palazhi:
Hi @Fran Rodríguez this should be fixed now. Do let us know should you see it again

Lisenet:
DockerHub added rate limits back in September 2020. For anonymous requests the limit is 100 pulls per six hours. If you make more requests from your IP address then you will get the error. You can authenticate if you have a DockerHub account, that would double the limit to 200 pulls per six hours.

Vijin Palazhi:
@Lisenet we just pushed an update to the labs. Are you facing this issue now?

Lisenet:
What was the update may I ask? Unless you use regcred, anonymous request will still be liable to 100 pulls per six hours.

Vijin Palazhi:
the fix is to use a registry mirror.

https://docs.docker.com/registry/recipes/mirror/

For example, you can make use of the GCR registry mirror as a pull through cache to get around this issue.

https://cloud.google.com/container-registry/docs/pulling-cached-images

Lisenet:
That’s nice, thanks!

Hello Kodekloud,

I am still getting ‘toomanyrequests’ error on running busybox

Normal SandboxChanged 24s (x3 over 28s) kubelet, node01 Pod sandbox changed, it will be killed and re-created.
Normal BackOff 21s (x5 over 27s) kubelet, node01 Back-off pulling image “busybox”
Warning Failed 21s (x5 over 27s) kubelet, node01 Error: ImagePullBackOff
Normal Pulling 7s (x2 over 30s) kubelet, node01 Pulling image “busybox”
Warning Failed 5s (x2 over 28s) kubelet, node01 Error: ErrImagePull
Warning Failed 5s kubelet, node01 Failed to pull image “busybox”: rpc error: code = Unknown desc = toomanyrequests: You have reached your pull rate limit. You may increase the limit by authenticating and upgrading: https://www.docker.com/increase-rate-limit
controlplane $