Hello All, I am practicing CKA labs.... Reg: Quiz No: 2 (Practice Test Trouble . . .

Raja g:
Hello All,

I am practicing CKA labs…

Reg: Quiz No: 2 (Practice Test Troubleshoot Network)

I tried my self to find the issue…, but I could not…

finally I checked the Hint given and came to know that the config file name was wrong in kube-proxy daemonset

  • command:
    - /usr/local/bin/kube-proxy
    - --config=/var/lib/kube-proxy/configuration.conf (should be “config.conf”)

Here I have doubt…

When I looked for the same file in the master node…
I could not find the kube-proxy dir…

controlplane cd /var/lib/ controlplane pwd
/var/lib
controlplane ls AccountsService dhcp ieee-data nfs snapd usb_modeswitch apt docker initramfs-tools ntp sudo usbutils atomic dockershim kubelet os-prober systemd vim binfmts dpkg logrotate pam ubuntu-release-upgrader weave cni etcd man-db plymouth ucf command-not-found gems misc polkit-1 update-manager containerd git mlocate private update-notifier dbus grub NetworkManager python ureadahead controlplane

if the dir is not present how it works… or else where exactly the dir exists…

Please correct/help me if I am wrong anywhere…

NOTE: But, yes… once I changed the filename to config.conf… it is working fine…

Mohamed Ayman:
The Configmap is a key-value pair so if you tried this command:
kubectl -n kube-system describe configmap kube-proxy
you can see config.conf that used in the daemon set and the Path kubeconfig: /var/lib/kube-proxy/kubeconfig.conf file is located inside config.conf in the container.

Mohamed Ayman:
Check the screenshot:

Mohamed Ayman:
Check the solution:
NetworkTroubleshooting-Q2.gif

Raja g:
Thanks MAyman. For the response… Really wow explanation… I got you… Cheers…:+1:

Tej_Singh_Rana:
> I could not find the kube-proxy dir…
Please see in the volume mounts and volumes in that definition file. You can find that location inside the pod (kubectl exec).

Raja g:
Yes Tej… I got it… Thanks