Haproxy LBR Troubleshooting - please help

Hello,

As the question states - “The monitoring tool recognised that there is an issue with the haproxy service on LBR server. That need to fixed to make the application work properly.”

We need to “Troubleshoot and fix the issue, and make sure haproxy service is running on Nautilus LBR server.”

Please find the screenshots -


I understand that below code to be added to set the haproxy port to 80

main frontend which proxys to the backends

#---------------------------------------------------------------------
frontend app_on_http_port_80 *:80
default_backend app_backend
#---------------------------------------------------------------------

round robin balancing between the various backends

#---------------------------------------------------------------------
backend app_backend
balance roundrobin
server stapp01 172.16.238.10:80 check
server stapp02 172.16.238.11:80 check
server stapp03 172.16.238.12:80 check

However updating the same in the /etc/haproxy/haproxy.conf file and restarting the service as
systemctl restart haproxy.service
still the service is in failed state

Not able to figure out exactly the issue, Please help

Thanks

you don’t need to change anything. According to 5th screen shot, you just have to uncomment that backend app section that’s it. Because task is only to fix the issue not to configure whole scenario again.

Thanks for the reply, However i uncommented the line “backend app” and restarted the haproxy and checked the status “systemctl status haproxy”
still provides the same error.

do journalctl -xe and provide screen shot

Thanks for the reply, i uncommented the line “backend app” and restarted the haproxy and checked the status, it worked

Haproxy service was active and the task is set success.

However Screenshot for journalctl -xe command

hi tej,

the status of the haproxy service points to timeout at line 57.
i could not find any issues there. please advise.


go down side of configuration file.


backend app section
you mentioned in your comments earlier to comment out backend app section.
is that the case? no where it asked to do this action.
Even after commenting backnd app section and restarting haproxy.


status message is still failing.

@Pallavi
how you resolved your issue with respect to haproxy service not getting started?
thanks

Hi Swaroopcs88,

I could see the #backend app line was commented in the configuration file, I removed the ‘#’ symbol that is uncommented, this was the only issue i fixed.
Then restarting the service and checking the status
service was active up and running,

Please uncomment “#backend app” line that is remove the ‘#’ symbol and save the file and check if the service gets active state.

are you sure? it is not commented for me.

@player001 @Pallavi
in my case it was a typo issue in timeout section that needed to be fixed.
I fixed the same and was able to finish the task.
thanks for your help.
Swaroop

1 Like

thanks great @swaroopcs88

Hi All,

I am getting this error when I did journalctl -xe

Could anyone help me in troubleshooting the error?

Your problem is commented out by # before backend app in 5 no screenshot. My problem was typo in haproxy config. Typo mistake was timeout clients but it should be timeout client. So i fixed it and start the haproxy. Beginners can see this tutorial: Linux Haproxy LBR Troubleshooting KodeKloud

KKE team ,

Please reset HAproxy LBR troubleshooting task for me.