Haproxy LBR task

Hi,
I executed the lbr haproxy task and did the work, i also verified the lbr connectivity with the 3 app server as you can see in the print screen, can you please indicate to me where is the error ??

@Inderpreet hi, any news about my query please ?

Hi @informixids

You also had to update haproxy configuration to make it use all three apps as back end. At the end you had to ensure that web page works on LBR link as mentioned in the question but I didn’t see that working in your answer.

Hi,
I verified twice that the 3 servers are added in the ha proxy configuration and i opened the web page normally in the browser. i verified all the work, but it seems that there was a problem with verification.

@Inderpreet please look at my work, i am sure i added the 3 servers and i showed the web page sucsessfully

Hi @informixids

We marked it Pending for you, please give it an another try.

Thank you very much, it sucsseded now.

I have failed this task two times but with the same configuration it worked on my homelab.

Hi @nobleaxis

Your back end configuration is incorrect. You had to make sure to use correct ports for each app in haproxy configuration whatever they are actually using. But seems like you simply used port 80
ha

Hi @Inderpreet, @peterwhite and other geeks…

Could you please help me whether i am on track with this task or am i gone wrong anywhere.
When trying to access the site for verifiying the task it says connecting… and stucks.

Please refer the below details and help me. I started from last rank and today i have gained 6500+ points and holds 183rd rank and these no.s keep me motivated to explore and learn more.

Kindly help… Thanks in advance.

Task assigned to me:
haproxy_tasknewquestion

Steps followed:
step 1: ssh root@172.16.238.14 and ran “yum install haproxy -y” and is success.

step2: edited haproxy.conf file as per the snip
haproxy_tasknew

step3: restarted haproxy service and status of service is running as per below snip

step4: tried accessing url as guided in task but getting below output

Regards,
Yogendra

Hi @yogendra,

If you scroll up to @Inderpreet’s comment on March 19th, you’ll see that you had the same problem with the same recommended correction. In your case, you should delete the app4 entry (there is no stapp04) and you’ll have to change the 5001,5002,5003 to match the port that that haproxy is routing to. I also change app1, app2, app3 to stapp01, stapp02, stap03 to match upwith the services that I’m routing to since I tend not to memorize IP address…

Peter

1 Like

Agreed with Peter. You can cross check by terminal select option by adding port 80, Display Port, which one is preconfigured in HAproxy configuration file. So don’t change HAproxy preconfigured port or match it is 80 or not.
Make sure ip values are correct, sometimes can’t help it.

Hi @peterwhite, @Inderpreet and others,

Kindly see below snips and help me where did i go wrong in this.

I got below success output page after accomplishing the task.
HAproxy_success

Howevere, task status showed failed with below error.
HAproxy_failed
All App servers were listening for httpd on 8082 and i configured same for app servers in haproxy file and port 80 for lbr server.

Could you please guide did i do it wrong or missed something.

Thanks,
Yogendra

can you share image of your HAProxy config file?

Hi @player001

I am sorry, as i got the desired output page i did not manage to take snip of the config file. I received failed status only after submitting the task :frowning:.

@Inderpreet, if possible please check from your end and let me know.

Else, i will wait for the task to reassign down the lane.

Thanks,
Yogendra

Hi @yogendra,

It’s probably too late for Kode Kloud to obtain server logs - I’m assuming they’re not using centralized log forwarding and that the logs are lost after the ec2 instances are terminated. For this reason, I ALWAYS screenshot all relevant files before clicking the finish button and would suggest that others do the same.

Peter