Getting timeout error while connecting to Centos machine on Oracle VM

Hi, I am trying to connect to Centos machine on oracle VM using ssh, but getting timeout error every time. Attaching the error messages and settings. am I missing any network setting ? Please help.

I checked the following

  1. sshd is up and running on centos
  2. using Bridge adapter
  3. I have Ubuntu machine on VM. I am able to ssh Centos machine from Ubuntu machine and vice versa but not able to connect to either of machines from host machine(windows 10)


Are you sure that’s the right machine to connect to? i assume that’s a VM sitting on that windows machine?
Can you check the VM if SSH is running and check log in /var/log/sshd/?

Hi istvan.berenyi,

Thank you for replying. yes, I have checked the ip address and it is correct. I could not locate the log file in above location, however using the command “systemctl status sshd” is showing ssh is active and is listening on port # 22.


I have 3 centos machines on Oracle Virtual Box. I am able to ssh among them but from host it is not connecting and giving timeout error.

Can you please share the screenshot of your VMs network settings from VirtualBox?

Thanks for that info.
if you can go between VM’s but you cannot go from your host machine to your VM than it is defnitely the VirtualBox Network settings we need to see.
Please include screenshots to proceed

Hi Tej, Thank you for replying !!

Please find the network settings below:

Hi istvan,

please refer to the screenshot of settings in the same thread above. Does that help ?

Hi Vamsikrishna,

Yes, it clearly shows -as i suspected from the address- that it’s a bridge setup.
Please change your network adapter to NAT on all machines, reboot your VM’s. They will get a new address and with that you will be able to SSH into them. Bridge network can be setup on your network but i’m not sure how to do that on windows as i don’t use it.

Hope that helps

Hi Istvan,

I changed to NAT and rebooted. got new IP but still getting the same timeout error :frowning:

Hi Vamsikrishna,

Thankfully i do not have to use windows for a number of years now, so i’m not too familiar how to troubleshoot more effectively.
Saying that,
Can you please go to your windows firewall settings and disable them? -temporarily-
Do you have any AV software installed with firewall in it? That might be blocking access to your VM’s.
Are you using corporate machine? Some enterprise setups may be blocking this.
Can you install Windows subsystem for linux? try SSH from there. It’s better to get used to bash/zsh than working from powershell, if you want to learn linux that is…

can you please go on to your VM’s and run : firewall-cmd --list-all



Hi Istvan,

I am using a corporate machine. I guess there could be some restrictions. I will try in my personal windows machine and let you know the result.
Thank you for you help !!

Hi vamsikrishna,
Any luck?

Hi Istvan,

I tried on my personal laptop (windows) over the weekend and it worked like a charm. I used Bridged adapter and was able to make ssh connection from my host system. As you guessed, there could be some firewall setting on my corporate machine.


Great to hear! Yes, Bridge adapter should work fine!
Enjoy the learning.