Fix issues with Lemp Stack

Hi @Inderpreet, @KodeKloud
I changed the nodeport to 30008 as expected and edited the config maps to port 80 as given in task.
The wordpress page too i was able to access on the nodeport.
I had it under review but so far nothing concrete. Please take a look

Hello, @ASAAC
Can you please tell me which website page you have seen after fixed issue?

I should have taken a screenshot. It was the default WordPress page to select a language.

You mean to say this one?
image

If it is, then your task is still pending. When you will access from the nodeport then it should be display preinstalled kodekloud website page.

yes this is the page. I retried the task and when this page came and I continued i noticed the DB was the issue

I think this is the correct page we should get.

@player001 @mohan08p @KodeKloud @Inderpreet Found that there was some wrong variable entry in wp-config.php file. Edited that by using below method. (And also modified ports needed)

thor@jump_host /$ kubectl exec -it nginx-wp-dp-5cb8759d9d-8kh57 pod --container php-fpm-container -- sh
# ls
index.php        wp-admin              wp-config.php  wp-links-opml.php  wp-settings.php
license.txt      wp-blog-header.php    wp-content     wp-load.php        wp-signup.php
readme.html      wp-comments-post.php  wp-cron.php    wp-login.php       wp-trackback.php
wp-activate.php  wp-config-sample.php  wp-includes    wp-mail.php        xmlrpc.php
#  

But still I am unable to see wordpress page. After editing config file do we need to restart POD or something?

hello guys @balu.networks7 and @ASAAC
how did you managed to finish this task? I am stuck in this task, fixed the wrong env. in the wp-config.php and changed the svc port and nodeport to 80 and 30008 but still not able to get the wp page? any hints would be greatly appreciated

This one is not the right web page. It’ll come with the name of KodeKloud Blog Page.

@nashwan Please make sure “app: lemp” (instead of php-fpm) in labels, services everywhere.

In my case above was the mistake.

@balu.networks7 thanks mate, that was the trick. appreciate your response.

1 Like