Fix issues with Lemp Stack - unclear or description issues

@Inderpreet @rahul456 @player001 @andrescaroc

I am stuck in this question, confused with the description. it says
Please do not change any existing deployment names, service names etc

while the current ngnix-service config port is 5009 and nodeport is 30002. and the questions asks to have it on port 80 and nodeport 30008.

Wordpress deployment name is nginx-wp-dp and MySQL deployment name is mysql-deployment . Nginx server must be configured to use port 80 , nodeport is 30008 and the document root for Nginx must be /var/www/html

Look into the issues and make sure WordPress website works on nodeport. Please do not change any existing deployment names, service names etc

Note:

  1. You should be able to load a preinstalled Wordpress website once issue is fixed so you should not get the installation page.

I would apreciate any correct direction if someone has.

thank you.

by the way, I did the following steps, but still not able to get the wp-page.

1- even tho not sure about the question description, I changed nginx-service port and node port to match what is been asked in the question. 80 and 30008.
2- changed the wrong env in wp-config.php
3- on the mysql pod, checked the db, and its table, verified they are exist.
but still no luck to get the wordpress page.

You may want to check the nginx-service selector as well. Sometime selector will have invalid values.

@sathish2032 thanks mate, that is a valid point, but what confused me is the question says dont change deployment and service name, etc, its a very grey description to me.

I don’t think so it’s quite confusing. It’s a straightforward, don’t modify existing deployment name, service name etc. Change what’s needed as per description.

Please try to run the command:

$ kubectl get ep

Let me know if you are still having an issue?

@player001 thanks for the reply. infact I was not sure if I am allowed to change anything in the service. I though this might be a description issue.

@sathish2032 huge thanks mate, looks like that was the missing part I wasnt paying much attention to it. that did the trick. appreciate that mate. thanks

@nashwan You are welcome. I just compensated for the last review mistake i have done for you :wink:

I think that one is the tricky part. If you knew how to process this kind of process. You don’t say its a description issue.
May be a service concepts(k8s) included in this scenario.
Good to hear that, you’re able to figure out the issue.

@sathish2032 not a problem mate, I knew it wasn’t on purposes so all good and no hard feeling what so ever.

Hi @rahul456 @player001 @Inderpreet @KodeKloud

Please see my open review here: https://www.kodekloud-engineer.com/#!/task_review?task_id=5fac3f5da8e70aa238be60c7

I have completed this task and achieving the expected result, yet it failed due to service 'type' for nginx is not 'LoadBalancer'. The description only specified not changing service names but nothing was regarding service types. With nodePort specified as 30008 for the service, I assumed service could as well be of type NodePort. The Wordpress site loaded as expected (please see screenshot below), so I’m surprised the task still failed. What could I have done differently?

@mmumshad @player001 @rahul456 @Inderpreet

Hey guys, could you please take a look at the issue I raised in my previous post? I would like to know where I stand. Thank you

@mmumshad @player001 @rahul456 @Inderpreet

I don’t understand why it takes so long to get some help. Meanwhile, I am stuck and unable to get a new task assigned while waiting to get issues resolved. Could you at least assign me new tasks while I wait for someone to look into this?

Also, I think having dedicated support would really go a long way in improving people’s learning experience on this platform. Really gets frustrating when one gets stuck and is unable to get help in reasonable time. Please look into this.

Thank you

@dcmexy, this is marked success for you, we have update the question description to make it more clear.

Hi @rahul456, thank you so much for addressing this. I have one more request. Seeing that I lost 2+ days waiting for this to be resolved, any chance I could get a new task assigned to me sooner rather than later?

Best regards