Fix issue with LAMP Environment in Kubernetes

This task has some problems.
The WordPress site was not set. and the error message is irrelevant.

Hi @Inderpreet @KodeKloud @player001 @rahul456

I have experienced a similar issue, just that mine did not even offer any reason for failure. I made relevant changes and the Wordpress installation page showed up. I don’t understand why it failed. Could you please check this for me?

I have an open review here: https://www.kodekloud-engineer.com/#!/task_review?task_id=5fa04caaa20908827916798b

Thank you.

@dcmexy, sorry for the issue, this is marked as pending for you, please give it an another try.

@Gurunath, you haven’t configured WordPress properly, a pre-configured web page should be working instead of WordPress Installation page.

Thanks @rahul456. It worked this time around.

@dcmexy I have same issue with this task.

  • changed the port on the lamp-service

  • recorrected the db env mistake

  • added DB_HOST to the env of the deployment, but still gewtting the wp installation page. any hint where else I should look at?

@rahul456 from what I sense in your above comments, we need to see a pre-configured wp page, and for that we will need a db with proper tables, etc. I keep getting wp install page!
Noticed one thing: checked the db table, looks like its empty. where should I get the table?
owners.

Type ‘help;’ or ‘\h’ for help. Type ‘\c’ to clear the current input statement.

mysql> show databases;
±-------------------+
| Database |
±-------------------+
| information_schema |
| kodekloud_db2 |
±-------------------+
2 rows in set (0.00 sec)

mysql> use kodekloud_db2;
Database changed
mysql> show tables;
Empty set (0.00 sec)

mysql>

checking /tmp/ of the jumphost and the container itself couldnt find any .sql db to import them. not sure if I am missing something here?

supper brilliant @sathish2032 you may have some good hints here that could help addressing this mystery?

thanks

Try only these two steps :slight_smile:

  • changed the port on the lamp-service, check selector is correct.
  • recorrected the db env mistake in php file only.

You should be getting the kodekloud wordpress page.

Dont add the environment variable in deployment file. I guess that will recreate the pod and wipe out all the kodekloud data. Try without adding it once.

@sathish2032 tried that too, no luck, still getting the wp install page, but I am curios to know why there is not table in the db? if there is no table how would we get the kodekloud page?

May be your lamp-wp deployment will run the required tables after successfully connecting to mysql-service? Is there any command or init container inside the deployment? I have not tried this task yet.

@nashwan have you recreated the pods by any chance in your task?

@sathish2032
tried all scenarios, with original pod, with changing the env in the deployment, that recreated the pod but the wp-config stayed as it is not impacted.

and yeah there is no command nor init container inside the deployment all I see is the apache and mysql container. that is what made me feel like there is something wrong with this task.

@KodeKloud @rahul456 would you be able to confirm that kodekloud wp page is what we have to see after fixing this issue?

Thanks

@nashwan, DB tables should be already there, if its coming blank for you then it might be some temporary issue. It can not be a persistent issue with this task as its working fine for others. Please try to reload. If you still see the same issue please share the screen shot of what you see.

@rahul456 @KodeKloud @Inderpreet @kodekloud-support3 there looks to be a persistant issue with the db table. I have tried more than 10 times everytime its same. In fact kodekloud_gem sometimes doesnt have privilege to access to db even after i grant that user full access. The table still shows empty. Please take a look at this issue i already wasted two days with this task not ticked off in my list
Here is a screenshoot used my mobile, since I cant upload photos from my laptop.

@rahul456 @KodeKloud @kodekloud-support3 @Inderpreet can you please look at this issue? already lost three days pending on this task which I am pretty sure it has db table issue.

@nashwan, we have assigned you a new task please procced with that one, we are investigating further issue with this one.

1 Like

@rahul456 thank you.

@rahul456 please let me know when I can retry this task, I also lost yesterday’s task. is it possible to be given a task for yesterday as well please?

the pending task (with issue) was for 10th Nov, I lost, 11th and 12th Nov’s task. and hopefully will get one for today 14th as well.

@rahul456,
I am having the same issue, has been on this task for 3 days too. would you assign me a new task while waiting for resolution?

thank you.

Jenna