Firewalld opening Port 8083 Failed

Hi
I am working on the below task.

The Nautilus system admins team recently deployed a web UI application for their backup utility running on the Nautilus backup server in Stratos Datacenter . The application is running on port 8083 . They have firewalld installed on that server. The requirements that have come up include the following:

Open all incoming connection on 8083/tcp port. Zone should be public .

When I have tried with the below command

firewall-cmd --zone=public --add-port=8083/tcp

But after restarting the firewalld service and checking the status I am seeing the below issue. Can any one please help me.

[root@stbkp01 etc]# systemctl restart firewalld
Job for firewalld.service failed because a timeout was exceeded. See “systemctl status firewalld.service” and “journalctl -xe” for details.
[root@stbkp01 etc]# systemctl status firewalld
● firewalld.service - firewalld - dynamic firewall daemon
Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled; vendor preset: enabled)
Active: failed (Result: timeout) since Mon 2020-07-06 00:16:39 UTC; 1min 5s ago
Docs: man:firewalld(1)
Process: 1527 ExecStart=/usr/sbin/firewalld --nofork --nopid $FIREWALLD_ARGS (code=exited, status=0/SUCCESS)
Main PID: 1527 (code=exited, status=0/SUCCESS)

Jul 06 00:16:32 stbkp01 systemd[1]: firewalld.service start operation timed out. Te…ng.
Jul 06 00:16:32 stbkp01 systemd[1]: firewalld.service changed start -> final-sigterm
Jul 06 00:16:39 stbkp01 systemd[1]: Child 1527 belongs to firewalld.service
Jul 06 00:16:39 stbkp01 systemd[1]: firewalld.service: main process exited, code=ex…ESS
Jul 06 00:16:39 stbkp01 systemd[1]: firewalld.service changed final-sigterm -> failed
Jul 06 00:16:39 stbkp01 systemd[1]: Job firewalld.service/start finished, result=failed
Jul 06 00:16:39 stbkp01 systemd[1]: Failed to start firewalld - dynamic firewall daemon.
Jul 06 00:16:39 stbkp01 systemd[1]: Unit firewalld.service entered failed state.
Jul 06 00:16:39 stbkp01 systemd[1]: firewalld.service failed.
Jul 06 00:16:39 stbkp01 systemd[1]: firewalld.service: cgroup is empty
Hint: Some lines were ellipsized, use -l to show in full.

journalctl -u firewalld ?

I have tried with journalctl -xe but no use.

You have to make it permanent and reload the firewalld by command or service.
add --permanent flag with firewall-cmd --zone=public --add-port=8083/tcp
and for reload firewall-cmd --reload

Thanks much!! It is working now :slight_smile:

@tvsraj how to switch to root from jump host because to execute the firewall-cmd command we need to be root . thanks in advance

Hi could you please guide me how to switch to root without password

Thanks in advance