Firewall task issue

I did everything correctly and port also showed open but still task was failed… i just want to know what was the mistake… PFA

Hi,

Your answer seems correct, this happened due to our maintenance work that was going on in the back-end. Sorry for this inconvenience. We marked your task as completed manually.

Thanks
Inderpreet

HI ,
i have run this command " firewall-cmd --permanent --zone=public --add-port=6000/tcp ", when i check list-port i’m not able see, then i re-run add-port command, it’s giving error message u have already added the port, after i saw the messages then i click on finish, but the task was got failed , let me know if any mistake have done…

hi, even i am also facing same kind of issue

thor@jump_host /$ sudo firewall-cmd --zone=public --permanent --add-service=8085/tcp
Error: DBUS_ERROR: Failed to connect to socket /run/dbus/system_bus_socket: No such file or directory

This command work for me. sudo firewall-cmd --zone=public --permanent --add-port=5003/tcp
I do not think you need the -service in the command.
Check this resource https://www.tecmint.com/install-configure-firewalld-in-centos-ubuntu/

1 Like

Hi Rakesh,

In your case, you have performed the required steps on jump_host itself however as per question you should have done this on Backup server. Hence your task was marked as failed.

Thanks
Inderpreet

Hi Kiran,

While adding the rule if you use --permanent option then you must reload/restart firewalld service after that to save the changes permanently. If you could have reloaded/restarted the service you could see the port in list-ports.
However as much I remember in this question you are not asked to add this rule permanently so you could skip --permanent option but again adding that should not fail the task but you need to make sure in that case you reload/restart the firewalld service.

Thanks
Inderpreet

Thanks for the update :+1:

image
Have the same problem.

image

Can please, explain why I got it wrong. Thanks

@jcorexx

Please share your email ID.